← Back to team overview

kernel-packages team mailing list archive

[Bug 1555775] PulseList.txt


apport information

** Attachment added: "PulseList.txt"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  WiFi + wired ethernet broken after suspend on Alienware 15 R2 (same on
  3x different WiFi cards)

Status in linux package in Ubuntu:

Bug description:
  I have an Alienware 15 R2 where the WiFi is broken on resume from
  suspend.  I thought it was likely my WiFi card, but I have an
  identical issue regardless of the three cards I have tried:

  1) Killer 1535
  2) Intel 8260
  3) Intel 7265

  All three work before suspend (the Killer required a firmware
  download), but after suspend, they are gone from network manager ("No
  network devices available"), from ifconfig, and from lshw -class

  I have tried removing the kernel module for the driver (ath10k and
  iwlwifi, respectively) before suspend and modprobe-ing it after, but
  that results in no change.  I also have disabled wifi via  the
  keyboard key, then suspended,  then resumed, but still no luck.  No
  change after installing intel-microcode either.

  Wifi does come back after resume in Windows.

  This post reports a similar problem:

  So my conclusion is that there's something going on with the
  motherboard/BIOS not turning any of the ethernet devices back on.  I
  am running the most up to date BIOS version.  I have tried the
  following distributions with identical results:

  Ubuntu 15.10 (stock kernel and 4.3 kernel)
  Xubuntu 14.04
  Linux Mint 17.3

  dmesg of a suspend/resume cycle in Ubuntu 15.10 with the stock kernel
  running the Intel 7265: http://pastebin.com/UsvwSbbM

  version.log for that dmesg:
  Ubuntu 4.2.0-30.36-generic 4.2.8-ckt3

  lshw -class Network (before suspend): http://pastebin.com/yhpUKjwv

  lspci-vnvn.log: http://pastebin.com/W6zfHLxE

  As a final note, the exact same thing happens to my wired ethernet connection as well (it disappears from lshw -class Network) after suspend.
  ApportVersion: 2.19.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  abarry     1585 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 15.10
  InstallationDate: Installed on 2016-03-10 (0 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 1bcf:2b8c Sunplus Innovation Technology Inc. 
   Bus 001 Device 003: ID 8087:0a2a Intel Corp. 
   Bus 001 Device 002: ID 187c:0528 Alienware Corporation 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Alienware Alienware 15 R2
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic.efi.signed root=UUID=115dc7cd-b190-4872-94bd-685ec9695732 ro noprompt persistent quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.2.0-30.36-generic 4.2.8-ckt3
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware                            1.149
  Tags:  wily
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  Uname: Linux 4.2.0-30-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/29/2016
  dmi.bios.vendor: Alienware
  dmi.bios.version: 1.2.8
  dmi.board.name: Alienware 15 R2
  dmi.board.vendor: Alienware
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Alienware
  dmi.chassis.version: Not Specified
  dmi.modalias: dmi:bvnAlienware:bvr1.2.8:bd01/29/2016:svnAlienware:pnAlienware15R2:pvr1.2.8:rvnAlienware:rnAlienware15R2:rvrA00:cvnAlienware:ct10:cvrNotSpecified:
  dmi.product.name: Alienware 15 R2
  dmi.product.version: 1.2.8
  dmi.sys.vendor: Alienware

To manage notifications about this bug go to: