← Back to team overview

kernel-packages team mailing list archive

[Bug 1554371] Re: [Regression] Volume keys not working after suspend/resume


I tried the latest mainline kernel from that PPA, and still have the
same issue.

And actually, I installed a bunch of updates today (turns out my mirror
was out of date, so I switched to a different one) and now it's even
worse - the media keys don't work even on a fresh boot.

** Tags added: kernel-bug-exists-upstream kernel-bug-exists-

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Regression] Volume keys not working after suspend/resume

Status in linux package in Ubuntu:

Bug description:
  I have a Microsoft Sculpt Ergonomic Desktop (keyboard/mouse combo). It
  was working great with Ubuntu 15.10. After upgrading to 16.04, the
  media keys stop working after suspending and resuming. This seems to
  be the relevant error from Xorg.log:

  [   176.121] (EE) evdev: Microsoft Microsoft® 2.4GHz Transceiver v9.0:
  Unable to open evdev device "/dev/input/event6".

  The USB receiver creates 5 devices:

  lrwxrwxrwx 1 root root   9 Mar  7 20:17 usb-Microsoft_Microsoft®_2.4GHz_Transceiver_v9.0-event-kbd -> ../event4
  lrwxrwxrwx 1 root root   9 Mar  7 20:17 usb-Microsoft_Microsoft®_2.4GHz_Transceiver_v9.0-if01-event-mouse -> ../event5
  lrwxrwxrwx 1 root root   9 Mar  7 20:17 usb-Microsoft_Microsoft®_2.4GHz_Transceiver_v9.0-if01-mouse -> ../mouse1
  lrwxrwxrwx 1 root root   9 Mar  7 20:17 usb-Microsoft_Microsoft®_2.4GHz_Transceiver_v9.0-if02-event-kbd -> ../event6
  lrwxrwxrwx 1 root root   6 Mar  7 20:17 usb-Microsoft_Microsoft®_2.4GHz_Transceiver_v9.0-if02-kbd -> ../js0

  After suspending and resuming, the last 2 devices (event6 and js0)

  I have tried booting up into the Vivid and Trusty kernels, and the
  problem persists, so at first glance it doesn't seem to be an issue
  with the kernel.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-4-generic 4.4.0-4.19
  ProcVersionSignature: Ubuntu 4.4.0-4.19-generic 4.4.1
  Uname: Linux 4.4.0-4-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  furkan     2733 F.... pulseaudio
   /dev/snd/controlC1:  furkan     2733 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Mon Mar  7 20:17:56 2016
  HibernationDevice: RESUME=UUID=a8eb7091-e848-4e63-82a1-8fa9562a3a61
  InstallationDate: Installed on 2014-06-06 (640 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: Gigabyte Technology Co., Ltd. GA-970A-D3
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-4-generic root=UUID=d254b01f-2bf2-4b57-acdc-c796786f4c4c ro
   linux-restricted-modules-4.4.0-4-generic N/A
   linux-backports-modules-4.4.0-4-generic  N/A
   linux-firmware                           1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-01-04 (63 days ago)
  dmi.bios.date: 05/30/2012
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F10
  dmi.board.name: GA-970A-D3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF10:bd05/30/2012:svnGigabyteTechnologyCo.,Ltd.:pnGA-970A-D3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-970A-D3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-970A-D3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: