← Back to team overview

kernel-packages team mailing list archive

[Bug 1552551] Re: Dell CERC Adapter hangs temporarily until reset. REGRESSION


Last of details I can supply unless someone wants me to test 14.10 or
15.04 releases.  I'd have to redownload or find a DVD and a drive that
reads them to PXE it since the only DVD I could find won't read in the
drives I have.

Ubuntu 9.10 works both 32 and 64 bit just fine.
15.10 hangs, both 32 and 64 bit.
Setting /sys/class/block/sd?/device/timeout to very small (5) or very large (90) doesn't help, but a small timeout seems to be less likely to return a read-error to userspace.
I tried the 4.5 rc7 candidate from upstream, as well as the rc6, and it still occurs there (64-bit only tested).
Booting with "nosmp" option at first seemed to help, I didn't get a hang until 95G had been read, but they were regular after that.


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Dell CERC Adapter hangs temporarily until reset.  REGRESSION

Status in linux package in Ubuntu:

Bug description:
  The HD CERC SATA 1.5 RAID controller (PCI-64 slot) hangs regularly for 10-60 seconds until reset.
  The CERC card firmware is the newest I can find reference to: 4.1-0 [bld 7419].  The Dell Poweredge 1800 has newest BIOS (A07).
  All hardware has been tested thoroughly OK except possibly the APIC component (Serverset Northbridge?).
  The 14.04LTS with all updates (or not) works fine with a perfectly consistent throughput of 77MB/s (slowest HD=66MB/s), RAID5.
  15.10 has the hangs of 10-60 seconds, AND with newest updates as of 26-FEB-2016.
  I do not have a 14.10 or 15.04 to test that I can get to boot on this system.
  I have changed PCI interrupts around and moved card slots to minimize sharing and removed cards - repeatedly.
  (It may not be possible to disable enough devices to completely avoid interrupt sharing).
  All hard drives and cables have been thoroughly tested, but the drives are mixed: 1 of 66MB/s, 1 of 125 MB/s, and 3 of 100MB/s.
  The drives not only work perfectly in 14.04LTS, but all Windows versions and DOS/BIOS-INT 19 as well (0x13).
  I believe I tried in Ubuntu 9.10 as well, but am only 85% certain.  If I did, it worked fine.
  I have tried all combinations of card RAID options Read ahead, Write cache, and other BIOS options.
  Relevant dmesg lines (these were consecutive):

  [ 1046.808027] aacraid: Host adapter abort request (4,0,0,0)
  [ 1046.808123] aacraid: Host adapter reset request. SCSI hang ?
  [ 1297.828038] aacraid: Host adapter abort request (4,0,0,0)
  [ 1297.828168] aacraid: Host adapter reset request. SCSI hang ?

  I run a repair shop, so I may not have access to the server for very
  long.  It's getting Windows reinstalled after RAM went bad and was
  replaced (and again, thoroughly tested through CPU and DMA channels
  (though not as through DMA)).


  00:00.0 Host bridge: Intel Corporation E7520 Memory Controller Hub (rev 09)
  00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 09)
  00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 09)
  00:06.0 PCI bridge: Intel Corporation E7520 PCI Express Port C (rev 09)
  00:1d.0 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
  00:1d.1 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
  00:1d.2 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
  00:1d.7 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
  00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
  00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
  00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
  00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
  01:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
  01:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
  02:05.0 RAID bus controller: Adaptec AAC-RAID (rev 01)
  02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
  03:07.0 Ethernet controller: Intel Corporation 82541GI Gigabit Ethernet Controller (rev 05)
  03:09.0 VGA compatible controller: NVIDIA Corporation NV18 [GeForce4 MX 4000] (rev c1)

  I'll attempt to attach a full dmesg and lspci.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-16-generic 4.2.0-16.19
  ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
  Uname: Linux 4.2.0-16-generic x86_64
  ApportVersion: 2.19.1-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CasperVersion: 1.365
  CurrentDesktop: Unity
  Date: Thu Mar  3 05:08:57 2016
  LiveMediaBuild: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: Dell Computer Corporation PowerEdge 1800
   PATH=(custom, no user)
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=u15.10-64/casper/vmlinuz.efi file=u15.10-64/preseed/username.seed boot=casper netboot=nfs nfsroot= initrd=u15.10-64/casper/initrd.lz ipv6.disable=1 net.ifnames=0
   linux-restricted-modules-4.2.0-16-generic N/A
   linux-backports-modules-4.2.0-16-generic  N/A
   linux-firmware                            1.149
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/29/2006
  dmi.bios.vendor: Dell Computer Corporation
  dmi.bios.version: A07
  dmi.board.name: 0P8611
  dmi.board.vendor: Dell Computer Corporation
  dmi.board.version: A04
  dmi.chassis.type: 17
  dmi.chassis.vendor: Dell Computer Corporation
  dmi.modalias: dmi:bvnDellComputerCorporation:bvrA07:bd09/29/2006:svnDellComputerCorporation:pnPowerEdge1800:pvr:rvnDellComputerCorporation:rn0P8611:rvrA04:cvnDellComputerCorporation:ct17:cvr:
  dmi.product.name: PowerEdge 1800
  dmi.sys.vendor: Dell Computer Corporation

To manage notifications about this bug go to: