← Back to team overview

kernel-packages team mailing list archive

[Bug 1556782] Re: USB3 not working


Did this issue start happening after an update/upgrade?  Was there a
prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:

Once testing of the upstream kernel is complete, please mark this bug as

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  USB3 not working

Status in linux package in Ubuntu:

Bug description:
  I am constantly getting these messages in dmesg:
  [114755.239681] usb 2-1: reset SuperSpeed USB device number 2 using xhci_hcd
  [114760.252354] usb 2-1: device descriptor read/8, error -110
  [114760.353433] usb 2-1: reset SuperSpeed USB device number 2 using xhci_hcd
  [114765.366486] usb 2-1: device descriptor read/8, error -110
  [114765.518703] sd 6:0:0:0: [sdf] FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
  [114765.518705] usb 2-1: USB disconnect, device number 2
  [114765.518707] sd 6:0:0:0: [sdf] CDB: 
  [114765.518708] Write(10): 2a 00 3a 36 db b7 00 00 10 00
  [114765.518712] blk_update_request: I/O error, dev sdf, sector 976673719
  [114765.518720] Aborting journal on device sdf1-8.
  [114765.524571] sd 6:0:0:0: [sdf] FAILED Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK

  I am trying to use a Toshiba external disk, in a usb3 port which I use for backup. It worked flawlessly on an old version of Redhat, but on moving to a new server, Intel S1200RP with updated firmware, I am in a world of pain. I have switched off standby for usb on boot, I have ensured that power is continually on for all usb ports. 
  I have tried a number of kernels, currently 3.19.0-031900rc4-lowlatency which had been less bad, but am still getting this fault.

To manage notifications about this bug go to: