← Back to team overview

kernel-packages team mailing list archive

[Bug 1557751] Re: makedumpfile generates kernel version error



First of all, I was wrong in my previous statement : 1.5.5 currently
supports kernels up to 3.19. The source code that you cite is for 1.5.9
that is only available in Xenial.

Secondly, there is no upstream version that supports kernel up to 4.2
since 1.5.9 is the last released upstream version. The current plans for
the next upstream version is to support kernels up to 4.2 so the problem
will remain with the lts-xenial kernel.

After reviewing the differences between 1.5.5 and 1.5.9, I only see one
kernel specific commit of interest, and it only enhances the current
behavior by using newly exported kernel information not available
beforehand. This will not impair the current functionality.

So I am not in a position to overrule upstream's decision to warn about
the fact that kernels above 4.1 are not supported.

I could backport the current situation but it will do you no good as it
will only bring the limit to 4.1. I prefer to wait for the newer release
that will provide a wider span of version support.

I will get in touch with upstream to see if there is any plan to bring
support for earlier kernels and up to what version they plan to confirm

Kind regards

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to makedumpfile in Ubuntu.

  makedumpfile generates kernel version error

Status in makedumpfile package in Ubuntu:
Status in makedumpfile source package in Trusty:

Bug description:
  == Comment: #7 - Vaishnavi Bhat  - 2016-03-15 06:16:53 ==
  The following warning is generated by makedumpfile 
  * running makedumpfile --dump-dmesg /proc/vmcore /mnt/201602030129/dmesg.201602030129
  The kernel version is not supported.
  The created dumpfile may be incomplete.

  The makedumpfile version on your machine is 
  # makedumpfile -v
  makedumpfile: version 1.5.5 (released on 18 Dec 2013)

  I did a #sudo apt-get source makedumpfile and checked for the sources. 
  In the makedumpfile.h ,  the LATEST_VERSION is set to
  #define OLDEST_VERSION          KERNEL_VERSION(2, 6, 15)/* linux-2.6.15 */
  #define LATEST_VERSION          KERNEL_VERSION(4, 1, 0)/* linux-4.1.0 */
  where as kernel version on the machine is 
  # uname -r

  Hence we see this mismatch and message as "The kernel version is not

  We need canonical to change the value of LATEST_VERSION  so that we do
  not see this message.

To manage notifications about this bug go to: