← Back to team overview

kernel-packages team mailing list archive

[Bug 1558646] Missing required logs.


This bug is missing log files that will aid in diagnosing the problem.
>From a terminal window please run:

apport-collect 1558646

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Apple Magic Keyboard A1644 fn key does not work

Status in linux package in Ubuntu:

Bug description:
  I recently purchased an Apple Magic Keyboard model #A1644 (the newest
  model).  Sadly, the fn key seems to be completely nonfunctional.  In
  other words, I cannot hold down fn+left arrow and get the equivalent
  of the Home key, etc.  It just ignores the fn key and behaves like a
  left arrow key.

  I am on Ubuntu 14.04.  version_signature output is:

  Ubuntu 3.13.0-37.64-generic

  Output from running hidd is:

  04:69:F8:D5:46:48 Magic Keyboard [004c:0267] connected

  FYI,  my function keys (F1-F12) work perfectly fine and are not
  mapping to media keys by default, but I had tried all the suggestions
  on the Ubuntu wiki anyway
  (https://help.ubuntu.com/community/AppleKeyboard, "Change Function Key
  behavior").  Still no go.  I suspect this is a kernel issue, since
  there was a bug report several years ago for back then's latest Apple
  wireless keyboard that had the same issue, and the kernel just needed
  a patch for the new device ID.  But who knows?

  Thanks in advance.

To manage notifications about this bug go to: