← Back to team overview

kernel-packages team mailing list archive

[Bug 1500242] Re: Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected with BQ Aquaris 4.5



We will try to resolve this issue, hopefully, in the coming days/weeks or get
closer to understanding the root cause. However before we start I would like you
to retest again because we have made a significant change recently with updating
the BlueZ version to 5.37 as well as we might have a fix for the Audi issue
already. If you could be so kind to give it a spin and report back on what is
happening that would be awesome.


1. Update the phone

The latest rc-proposed would be a good choice as we are pushing good stuff into
it. Make sure that the phone runs bluez 5.37 by executing:

$ dpkg -l bluez

2. Install the silo with the possible Audi fix (see comments below)

I saw that you were able to install to rc-proposed on your own therefore I
suggest trying the silo too. However if you feel uncertain about this just skip
it as eventually whatever is in silos finds it's way to rc-proposed quite fast.

In order to install a silo you need to install phablet-tools package on your
Ubuntu running computer. The PPA is here:

Installing a silo is done by executing command

$ citrain device-upgrade <silo-number> <pin-code>

where the silo-number indicates the silo which you would like to install and the
pin code indicates the four-digit code that you use to unlock the phone [it
happens to be the user password too]. So for this silo you need to run:

$ citrain device-upgrade 67 <your-pin>

The citrain tool will install everything for you and reboot the phone.


I would like you to try these scenarios again with both Audi and Jabra. If you
observe that if still is buggy then please capture the logas as you did

Let me know if there is anything that I could clarify more regarding updating
and such.


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected
  with BQ Aquaris 4.5

Status in Canonical System Image:
Status in bluez package in Ubuntu:
Status in ofono package in Ubuntu:

Bug description:
  Requirements: Aquaris E4.5, Jabra BT250 blue tooth handset device (rather old one supports blue tooth 1.1 and therefore I thought should be no issue) or Audi car kit (A3 2012 model)

  1. Put Jabra BT250 into receiving mode
  2. Phone searches automatically every 15 - 30 seconds for a new blue tooth device
  3. Phone finds Jabra BT250 and asks for pairing code
  4. Enter code into phone
  5. Jabra BT250 automatically exits the pairing mode (which is a sign that pairing should have worked)
  6. Phone looses connection to Jabra BT250
  7. Manual reconnection via phone works (shows Jabra BT250 as being connected) but ignores the device

  Same behaviour with Audi car kit (Audi A3, 2012 model)

  I expect that the blue tooth kits work similar to my Seat Alhambra (also 2012 model) where the blue tooth pairing etc. works great (except some bugs which are already filed).

  No connection to the blue tooth device

  OS-Build-Number: 25
  Ubuntu-Image: 20150825.1

  Is this issue also solved as soon as bluez5 is implemented? When will this be?

To manage notifications about this bug go to: