← Back to team overview

kernel-packages team mailing list archive

[Bug 1500242] Re: Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected with BQ Aquaris 4.5


Hi Konrad,

thanks for working on this issue!

I am on the following version:

current build number: 286
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-03-18 08:33:28
version version: 286
version ubuntu: 20160318
version device: 20160108-efc96d8
version custom: 20160111-926-36--vivid

I have checked with above command that bluez 5.37 is installed.

I have checked if the Jabra 250 works before installing silo 67 and I
experienced the same behaviour as before: directly after the pairing
process it works as expected and as soon as I shut off the bluetooth
device and reconnect this connection does not work.

I then followed step 2. I have installed silo 67. Just to cross check: I
got from the terminal the information that the following parts will be

The following NEW packages will be installed:
The following packages will be upgraded:
  libsystemsettings1 ubuntu-system-settings
2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,240 kB of archives.
After this operation, 517 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/ vivid/main libgeonames0 armhf 0.1+15.04.20160315-0ubuntu1 [352 kB]
Get:2 http://ppa.launchpad.net/ci-train-ppa-service/landing-067/ubuntu/ vivid/main ubuntu-system-settings armhf 0.3+15.04.20160318-0ubuntu1 [880 kB]
Get:3 http://ppa.launchpad.net/ci-train-ppa-service/landing-067/ubuntu/ vivid/main libsystemsettings1 armhf 0.3+15.04.20160318-0ubuntu1 [8,114 B]

Is this as you have expected? I then tried to reconnect the Audi A3. It
did not work. But I got a bit further than during my last attempts. The
phone seemed to be able to extablish a connection (but the car did not
verify this connection, it just said in the IN CAR display: "please wait

I was able to start a command line while the phone was connected to
start bluetoothctl:

[Audi UHV 4272]# info
Device 00:0E:9F:E8:3A:24
	Name: Audi UHV 4272
	Alias: Audi UHV 4272
	Class: 0x200408
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no

But finally I had to give up after several connections and

Log files are attached. Best success in finding the root cause!

If I can help furhter, please let me know!

** Attachment added: "20160318_2146.tar.gz"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected
  with BQ Aquaris 4.5

Status in Canonical System Image:
  In Progress
Status in bluez package in Ubuntu:
Status in ofono package in Ubuntu:

Bug description:
  Requirements: Aquaris E4.5, Jabra BT250 blue tooth handset device (rather old one supports blue tooth 1.1 and therefore I thought should be no issue) or Audi car kit (A3 2012 model)

  1. Put Jabra BT250 into receiving mode
  2. Phone searches automatically every 15 - 30 seconds for a new blue tooth device
  3. Phone finds Jabra BT250 and asks for pairing code
  4. Enter code into phone
  5. Jabra BT250 automatically exits the pairing mode (which is a sign that pairing should have worked)
  6. Phone looses connection to Jabra BT250
  7. Manual reconnection via phone works (shows Jabra BT250 as being connected) but ignores the device

  Same behaviour with Audi car kit (Audi A3, 2012 model)

  I expect that the blue tooth kits work similar to my Seat Alhambra (also 2012 model) where the blue tooth pairing etc. works great (except some bugs which are already filed).

  No connection to the blue tooth device

  OS-Build-Number: 25
  Ubuntu-Image: 20150825.1

  Is this issue also solved as soon as bluez5 is implemented? When will this be?

To manage notifications about this bug go to: