← Back to team overview

kernel-packages team mailing list archive

[Bug 1555775] Re: WiFi + wired ethernet broken after suspend on Alienware 15 R2


** Attachment added: "dmesg_devices_wifi_ok.txt"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  WiFi + wired ethernet broken after suspend on Alienware 15 R2

Status in linux package in Ubuntu:

Bug description:
  With Ubuntu 14.04, and 15.10, using my Alienware 15 R2 the Intel 7265
  WiFi is broken on resume from suspend. However, after suspend, it is
  gone from network manager ("No network devices available"), from
  ifconfig, and from lshw -class Network. It works fine prior to

  I have tried removing the kernel module iwlwifi,before suspend and
  modprobe-ing it after, but that results in no change. I also have
  disabled wifi via the keyboard key, then suspended, then resumed, but
  still no luck. No change after installing intel-microcode either.

  Wifi does come back after resume in Windows.

  As additional data points:
  This also happens with WiFi cards Killer 1535, and Intel 8260.
  Also, the exact same thing happens to my wired ethernet connection as well (it disappears from lshw -class Network) after suspend.

  ApportVersion: 2.19.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  abarry     1585 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 15.10
  InstallationDate: Installed on 2016-03-10 (0 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 1bcf:2b8c Sunplus Innovation Technology Inc.
   Bus 001 Device 003: ID 8087:0a2a Intel Corp.
   Bus 001 Device 002: ID 187c:0528 Alienware Corporation
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Alienware Alienware 15 R2
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic.efi.signed root=UUID=115dc7cd-b190-4872-94bd-685ec9695732 ro noprompt persistent quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.2.0-30.36-generic 4.2.8-ckt3
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware                            1.149
  Tags:  wily
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  Uname: Linux 4.2.0-30-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 01/29/2016
  dmi.bios.vendor: Alienware
  dmi.bios.version: 1.2.8
  dmi.board.name: Alienware 15 R2
  dmi.board.vendor: Alienware
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Alienware
  dmi.chassis.version: Not Specified
  dmi.modalias: dmi:bvnAlienware:bvr1.2.8:bd01/29/2016:svnAlienware:pnAlienware15R2:pvr1.2.8:rvnAlienware:rnAlienware15R2:rvrA00:cvnAlienware:ct10:cvrNotSpecified:
  dmi.product.name: Alienware 15 R2
  dmi.product.version: 1.2.8
  dmi.sys.vendor: Alienware

To manage notifications about this bug go to: