← Back to team overview

kernel-packages team mailing list archive

[Bug 1561830] [NEW] Hard disk writes fail in 16.04 daily on nForce 430


You have been subscribed to a public bug:

I have an old PC I use for testing new operating systems.  It has
previously had Ubuntu 15.10 installed and working.  The motherboard is
an Asus M2NPV-VM, with Nvidia nForce 430 chipset and Nvidia GeForce 6150
GPU.  I have installed an Nvidia GT220 card to use for more modern video

When I attempt to install Ubuntu 16.04 beta (daily xenial-desktop-
amd64.iso file downloaded 24/03/2016  18:17), it starts to write to the
hard disk (Samsung HD103UJ), and after a short time the install got lots
of disk write errors in kern.log.  After the errors, the disk was unable
to be read either, with "fdisk -l /dev/sda" failing to read a sector,
where it had worked before starting the install.  Unplugging the SATA
cable to the drive and plugging it in again made the drive work again
(on /dev/sdc), but another attempt to install failed with the same write

I noticed that the log had swap write errors also, so I rebooted the
install DVD again, and this time did a "swapoff -a" command before
attempting to install, but got the same errors again.  So I found my
Ubuntu 15.10 install DVD and tried a new install from that, which worked
just fine.

On rebooting with my 16.04 daily DVD, I again did "swapoff -a" so that
the DVD based system would run normally, then tried mounting the EXT4
system partition I had just installed using the 15.10 install DVD.  That
worked, so I tried dd commands to do test writes to that partition.  The
following commands worked:

  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=10k
  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=100k

but when I did this command:

  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=1000k

after a while errors started appearing in kern.log, just as with the
attempts to install 16.04.

It appears that with sustained write activity, the errors will start and
then the drive will become unusable until it is unplugged and plugged in

I have attached the kern.log and syslog files from the 15.10 install
that worked, and the 16.04 install attempt that failed.  The first error
message appears to be this:

ata3: EH in SWNCQ mode,QC:qc_active 0x1FFF sactive 0x1FFF
ata3: SWNCQ:qc_active 0x1 defer_bits 0x1FFE last_issue_tag 0x0
dhfis 0x1 dmafis 0x0 sdbfis 0x0

which leads me to suspect a problem with the handling of the SATA
controller's interrupts.

** Affects: linux (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: bot-comment
Hard disk writes fail in 16.04 daily on nForce 430
You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.