← Back to team overview

kernel-packages team mailing list archive

[Bug 1561830] ProcInterrupts.txt


apport information

** Attachment added: "ProcInterrupts.txt"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Hard disk writes fail in 16.04 daily on nForce 430

Status in linux package in Ubuntu:

Bug description:
  I have an old PC I use for testing new operating systems.  It has
  previously had Ubuntu 15.10 installed and working.  The motherboard is
  an Asus M2NPV-VM, with Nvidia nForce 430 chipset and Nvidia GeForce
  6150 GPU.  I have installed an Nvidia GT220 card to use for more
  modern video support.

  When I attempt to install Ubuntu 16.04 beta (daily xenial-desktop-
  amd64.iso file downloaded 24/03/2016  18:17), it starts to write to
  the hard disk (Samsung HD103UJ), and after a short time the install
  got lots of disk write errors in kern.log.  After the errors, the disk
  was unable to be read either, with "fdisk -l /dev/sda" failing to read
  a sector, where it had worked before starting the install.  Unplugging
  the SATA cable to the drive and plugging it in again made the drive
  work again (on /dev/sdc), but another attempt to install failed with
  the same write errors.

  I noticed that the log had swap write errors also, so I rebooted the
  install DVD again, and this time did a "swapoff -a" command before
  attempting to install, but got the same errors again.  So I found my
  Ubuntu 15.10 install DVD and tried a new install from that, which
  worked just fine.

  On rebooting with my 16.04 daily DVD, I again did "swapoff -a" so that
  the DVD based system would run normally, then tried mounting the EXT4
  system partition I had just installed using the 15.10 install DVD.
  That worked, so I tried dd commands to do test writes to that
  partition.  The following commands worked:

    dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=10k
    dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=100k

  but when I did this command:

    dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=1000k

  after a while errors started appearing in kern.log, just as with the
  attempts to install 16.04.

  It appears that with sustained write activity, the errors will start
  and then the drive will become unusable until it is unplugged and
  plugged in again.

  I have attached the kern.log and syslog files from the 15.10 install
  that worked, and the 16.04 install attempt that failed.  The first
  error message appears to be this:

  ata3: EH in SWNCQ mode,QC:qc_active 0x1FFF sactive 0x1FFF
  ata3: SWNCQ:qc_active 0x1 defer_bits 0x1FFE last_issue_tag 0x0
  dhfis 0x1 dmafis 0x0 sdbfis 0x0

  which leads me to suspect a problem with the handling of the SATA controller's interrupts.
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  ubuntu     2233 F.... pulseaudio
   /dev/snd/controlC1:  ubuntu     2233 F.... pulseaudio
  CasperVersion: 1.368
  DistroRelease: Ubuntu 16.04
   enp0s20   no wireless extensions.
   lo        no wireless extensions.
   enp2s9    no wireless extensions.
  LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 002: ID 0458:0118 KYE Systems Corp. (Mouse Systems) 
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: System manufacturer System Product Name
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash ---
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware                            1.157
  Tags:  xenial
  Uname: Linux 4.4.0-15-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  _MarkForUpload: True
  dmi.bios.date: 08/07/2008
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: ASUS M2NPV-VM ACPI BIOS Revision 1401
  dmi.board.name: M2NPV-VM
  dmi.board.vendor: ASUSTek Computer INC.
  dmi.board.version: 1.xx
  dmi.chassis.asset.tag: 123456789000
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2NPV-VMACPIBIOSRevision1401:bd08/07/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTekComputerINC.:rnM2NPV-VM:rvr1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: