← Back to team overview

kernel-packages team mailing list archive

[Bug 1500242] Re: Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected with BQ Aquaris 4.5



I hope I did what you have expected:

at first I tried to forget the device (Seat_BT, 4C:74:03:64:75:ED). But
even after that and after a reboot I could find a directory with the
address of the device in (var/lib/bluetooth/4C:74:03:64:75:ED).

In a second step I deleted the content of the bluetooth directory with:

sudo rm /var/lib/bluetooth/* -rf

The directory was then empty - as expected.

In a second step I reconnected my Seat_BT with the phone. It worked
again as it should. If you are looking at the logs it was at 30.03.2016
at approx 18:08 h CET. (You can also find the same attempts earlier). I
can do calls, listen to music, etc.

I then also tested the Audi (30.03.2016 20:45 h CET). For this test I
have not deleted the profile of the Seat_BT - should I??

During the attempt to connect to the Audi I still have the same issue as

The phone finds the Audi as "Audi UHV 4272". 
The phone asks for the pairing key (1234). This is the correct key since another phone can be connected to the Audi with this pairing key.
It creates an entry in the list of devices in system-settings, bluetooth menu. 
But in var/lib/bluetooth/ no additional directory has been added.

But the car itself never recognizes that a phone is connected to the

Approx. 30 seconds after the connection it (phone or car? I do not know) disconnects again. 
Waiting for approx. 30 - 60 sec. repeats this action (connect, after approx. 30 seconds disconnect).

I have attached the logs again.

I will "loose" my test candidate (the Seat_BT) tomorrow since I have to
hand in the car again. So for the Seat device I can not do any more
testing. I will keep the Audi and the Jabra250! The ones that do not
work with my phone :-((  ...  ;-) ..


** Attachment added: "20160330_2052.tar.gz"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Bluetooth devices (Jabra BT250, Audi A3 car kit) can not be connected
  with BQ Aquaris 4.5

Status in Canonical System Image:
  In Progress
Status in bluez package in Ubuntu:
Status in ofono package in Ubuntu:

Bug description:
  Requirements: Aquaris E4.5, Jabra BT250 blue tooth handset device (rather old one supports blue tooth 1.1 and therefore I thought should be no issue) or Audi car kit (A3 2012 model)

  1. Put Jabra BT250 into receiving mode
  2. Phone searches automatically every 15 - 30 seconds for a new blue tooth device
  3. Phone finds Jabra BT250 and asks for pairing code
  4. Enter code into phone
  5. Jabra BT250 automatically exits the pairing mode (which is a sign that pairing should have worked)
  6. Phone looses connection to Jabra BT250
  7. Manual reconnection via phone works (shows Jabra BT250 as being connected) but ignores the device

  Same behaviour with Audi car kit (Audi A3, 2012 model)

  I expect that the blue tooth kits work similar to my Seat Alhambra (also 2012 model) where the blue tooth pairing etc. works great (except some bugs which are already filed).

  No connection to the blue tooth device

  OS-Build-Number: 25
  Ubuntu-Image: 20150825.1

  Is this issue also solved as soon as bluez5 is implemented? When will this be?

To manage notifications about this bug go to: