← Back to team overview

kernel-packages team mailing list archive

[Bug 1561902] Re: Total system freeze after 3.16.0-38.52


Thanks for the ideas! Did you mean 3.16.0-67 and not -87? I tried -67
now with and without vesafb:mtrr:0. System freezes within minutes in
both cases.

I also tried mainline 3.16.7-ckt26-trusty and added vesafb:mtrr:3 to
this and the system does NOT seem to freeze. This bug is weird.
3.16.0-38 was the first kernel with problems and mtrr was the only
change that is not included in mainline. Why are mainline kernels
working and normal not...? I want to believe that setting vesafb:mtrr:3
as boot parameter is exactly the same as setting mtrr = 3 in source
code. (as said here

No ctrl-alt-f1 or alt-ctrl-sysrq is possible when the system has frozen.
Nothing works. Not even the WiFi LED from the hardware switch. I started
a "find *.* /" after 3.16.0-67 boot and noticed that all disc activity
stopped when system freezes. That probably tells that this is not just
keyboard/mouse/graphics issue?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-lts-utopic in Ubuntu.

  Total system freeze after 3.16.0-38.52

Status in linux-lts-utopic package in Ubuntu:

Bug description:
  This should have been reported already last year, but here it goes.

  My laptop is a ASUS N71JA and works perfectly in Windows. Everything was fine with Xubuntu 14.04 through kernels 3.13 and 3.16 up to 3.16.0-38.52. Desktop freezes, like totally dies with hard power reset being the only option, every now and then from this kernel and onwards. This affects 3.19 and 4.2.0 kernels released after this date as well. No Magic SysRq possible and I can't see anything fancy in syslog or kern.log. Desktop can die anytime between immediately after boot or after a few hours, but it happens completely randomly and is hard to debug.

  3.16.0-38.52 was released in May 2015 (https://bugs.launchpad.net/ubuntu/+source/linux-lts-utopic/+bug/1452882).
  3.16.0-37.51 and 3.16.0-36.48 have NEVER frozen. 

  The only non-upstream change that was made to 3.16.0-38.52 was
  "vesafb: Set mtrr:3 (write-combining) as default"
  (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1434581). This
  is probably not implemented in the mainline kernel tree, right? I've
  been using mainline 3.16.7-ckt24-trusty without any problems now for
  over a month (http://kernel.ubuntu.com/~kernel-
  ppa/mainline/v3.16.7-ckt24-trusty/) i.e. it seems like 1434581 is
  causing the problem.

  Can this be verified by some other method e.g. by disabling/reverting
  1434581 in a "normal" non-mainline kernel?

  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
   /dev/snd/controlC2:  isak       1669 F.... pulseaudio
   /dev/snd/controlC0:  isak       1669 F.... pulseaudio
   /dev/snd/controlC1:  isak       1669 F.... pulseaudio
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=188824e0-028f-4004-92b9-9e627eff4d5c
  MachineType: ASUSTeK Computer Inc. N71Ja
  Package: linux (not installed)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-38-generic root=UUID=1d243640-e961-4ee3-b6d9-8e4ee5816090 ro quiet splash
  ProcVersionSignature: Ubuntu 3.16.0-38.52~14.04.1-generic 3.16.7-ckt10
   linux-restricted-modules-3.16.0-38-generic N/A
   linux-backports-modules-3.16.0-38-generic  N/A
   linux-firmware                             1.127.20
  Tags:  trusty
  Uname: Linux 3.16.0-38-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
  _MarkForUpload: True
  dmi.bios.date: 05/14/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: N71Ja.206
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: N71Ja
  dmi.board.vendor: ASUSTeK Computer Inc.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK Computer Inc.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN71Ja.206:bd05/14/2010:svnASUSTeKComputerInc.:pnN71Ja:pvr1.0:rvnASUSTeKComputerInc.:rnN71Ja:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
  dmi.product.name: N71Ja
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK Computer Inc.

To manage notifications about this bug go to: