← Back to team overview

kernel-packages team mailing list archive

[Bug 1568211] Re: no UMS support in radeon module


I am also affected by this bug after upgrading to Xenial and trying to
use radeon KMS. My system will only boot with `nomodeset` or
`radeon.modeset=0`. Futhermore, attempting `sudo modprobe radeon
modeset=1` after booting with `nomodeset` results in the same error
state: screen goes blank, monitor's "No signal detected" message
appears. Sometimes the machine reboots, but not always.

I have a Radeon HD5770 card. I will try to attach logs via apport

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  no UMS support in radeon module

Status in linux package in Ubuntu:

Bug description:
  I upgraded overnight from Wily to Xenial. The system will not boot.
  Only a blank screen after grub loads the kernel.

  The recovery kernel loads fine and I was able to find the following

  [drm] VGACON disable radeon kernel modesetting
  [drm:radeon_init [radeon]] *ERROR* no UMS support in radeon module!

  The recovery kernel command line had a nomodeset parameter that was
  not in the main kernel command line.

  Adding the nomodeset parameter the main kernel command line finally
  booted the system. It's kind of ugly but it seems to work.

  Note: For what it's worth I reported a similar issue against several
  Utopic kernels (bug #1407505). There was a back and forth with
  jsalisbury until a kernel finally worked. I have had no problems until

  Hope that helps.

To manage notifications about this bug go to: