← Back to team overview

kernel-packages team mailing list archive

[Bug 1567309] Re: X freezes since upgrade to linux-image-4.2.0-35-generic


I have some issues with apport-collect and openssl. But anyway, I got
some details opening a ssh connection while reproducing the issue (which
is good, because then is more a drivers issue than anything in the core
syssystems of the kernel).

This is what dmesg outputs when the X freezes:

[   16.171794] Bluetooth: RFCOMM TTY layer initialized
[   16.171801] Bluetooth: RFCOMM socket layer initialized
[   16.171806] Bluetooth: RFCOMM ver 1.11
[   16.172874] Non-volatile memory driver v1.3
[   17.014534] audit: type=1400 audit(1460365125.847:27): apparmor="DENIED" operation="open" profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/dconf/profile/gdm" pid=2443 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=117 ouid=0
[   17.048189] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   17.048359] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   73.649420] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   74.351892] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   74.352049] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[   74.352195] [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
[  179.823180] BUG: unable to handle kernel NULL pointer dereference at           (null)
[  179.823207] IP: [<          (null)>]           (null)
[  179.823220] PGD 355f7067 PUD c5d99067 PMD 0 
[  179.823233] Oops: 0010 [#1] SMP 
[  179.823244] Modules linked in: nvram rfcomm msr drbg ansi_cprng ctr ccm xt_conntrack ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 xt_addrtype iptable_filter ip_tables x_tables nf_nat nf_conntrack br_netfilter bridge stp llc dm_thin_pool dm_persistent_data dm_bio_prison dm_bufio libcrc32c binfmt_misc bnep uvcvideo btusb videobuf2_vmalloc btrtl videobuf2_memops btbcm videobuf2_core btintel v4l2_common bluetooth videodev media intel_rapl x86_pkg_temp_thermal intel_powerclamp kvm_intel nls_iso8859_1 kvm dell_wmi arc4 dell_laptop sparse_keymap dcdbas crct10dif_pclmul crc32_pclmul dell_smm_hwmon iwlmvm mac80211 aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper iwlwifi cryptd joydev input_leds serio_raw snd_hda_codec_realtek snd_soc_rt5640 snd_hda_codec_hdmi
[  179.823476]  cfg80211 snd_soc_rl6231 snd_hda_codec_generic snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel snd_hda_codec lpc_ich snd_hda_core snd_seq_midi snd_seq_midi_event snd_hwdep mei_me snd_pcm mei snd_rawmidi shpchp snd_seq snd_seq_device int3403_thermal snd_timer 8250_fintek dell_smo8800 snd dw_dmac dw_dmac_core soundcore snd_soc_sst_acpi 8250_dw i2c_designware_platform spi_pxa2xx_platform int3400_thermal int3402_thermal i2c_designware_core processor_thermal_device dell_rbtn intel_soc_dts_iosf int340x_thermal_zone acpi_thermal_rel acpi_pad acpi_als kfifo_buf mac_hid industrialio coretemp parport_pc ppdev lp parport autofs4 btrfs xor raid6_pq ahci libahci i915 psmouse e1000e i2c_algo_bit drm_kms_helper ptp pps_core drm sdhci_pci wmi video sdhci_acpi sdhci i2c_hid hid
[  179.823704] CPU: 3 PID: 3203 Comm: gnome-shell Tainted: G     U          4.2.0-35-generic #40-Ubuntu
[  179.823726] Hardware name: Dell Inc. Latitude E7450/06HN6G, BIOS A02 12/29/2014
[  179.823743] task: ffff8800d9412940 ti: ffff8804090b4000 task.ti: ffff8804090b4000
[  179.823761] RIP: 0010:[<0000000000000000>]  [<          (null)>]           (null)
[  179.823780] RSP: 0018:ffff8804090b7ac0  EFLAGS: 00010282
[  179.823793] RAX: ffff8800358143d0 RBX: 0000000000000001 RCX: 2591e94884ce32ad
[  179.823809] RDX: 00000000fffff4c4 RSI: ffff8800358143c8 RDI: ffff880035811f28
[  179.823826] RBP: ffff8804090b7b48 R08: 0000000000000000 R09: ffff880388e42840
[  179.823843] R10: ffff88040a036600 R11: 00000000000000c0 R12: ffff880035811f28
[  179.823859] R13: 0000000000000000 R14: ffff8800358143c8 R15: ffff880388c87b40
[  179.823876] FS:  00007f278cae4a80(0000) GS:ffff88041e580000(0000) knlGS:0000000000000000
[  179.823896] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  179.823909] CR2: 0000000000000000 CR3: 00000000c5e45000 CR4: 00000000003406e0
[  179.823926] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[  179.823943] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[  179.823960] Stack:
[  179.823966]  ffffffffc01d7e76 0000000000007d60 ffff8800358143d0 fffff4c400000004
[  179.823986]  ffff8800d9969b00 ffff880388c87b40 0000000000048000 0000000200000002
[  179.824007]  0000000000000029 0000000000000560 0000000064ba35aa 0000000200000002
[  179.824027] Call Trace:
[  179.824055]  [<ffffffffc01d7e76>] ? i915_gem_object_sync+0x196/0x290 [i915]
[  179.824083]  [<ffffffffc01f3288>] intel_execlists_submission+0x288/0x530 [i915]
[  179.824110]  [<ffffffffc01cd075>] i915_gem_do_execbuffer.isra.27+0x935/0x10a0 [i915]
[  179.824130]  [<ffffffff817f66f6>] ? mutex_lock_interruptible+0x16/0x50
[  179.824147]  [<ffffffff811e1deb>] ? __kmalloc+0x1cb/0x270
[  179.824170]  [<ffffffffc01ce912>] i915_gem_execbuffer2+0xb2/0x240 [i915]
[  179.824199]  [<ffffffffc0083505>] drm_ioctl+0x125/0x610 [drm]
[  179.824222]  [<ffffffffc01ce860>] ? i915_gem_execbuffer+0x310/0x310 [i915]
[  179.824261]  [<ffffffff81213cd5>] do_vfs_ioctl+0x295/0x480
[  179.824289]  [<ffffffff816d031c>] ? __sys_recvmsg+0x8c/0xa0
[  179.824303]  [<ffffffff81213f39>] SyS_ioctl+0x79/0x90
[  179.824316]  [<ffffffff817f8c72>] entry_SYSCALL_64_fastpath+0x16/0x75
[  179.824331] Code:  Bad RIP value.
[  179.824342] RIP  [<          (null)>]           (null)
[  179.824355]  RSP <ffff8804090b7ac0>
[  179.824364] CR2: 0000000000000000
[  179.830221] ---[ end trace f62b717d9bed166b ]---

Any idea where to start to check?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  X freezes since upgrade to linux-image-4.2.0-35-generic

Status in linux package in Ubuntu:

Bug description:
  After upgrading to linux-image-4.2.0-35-generic from wily-security my
  X freezes after a while (random time, but never more than 2 minutes).
  If when the GDM prompt I switch to the terminal, then the laptop runs

  Booting with 4.2.0-30-generic works fine.

  Sound quite related to
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1527115 But I
  tried with the Kernel Mainline Builds (both linux-
  image-4.4.0-040400-generic and linux-image-4.5.0-040500-generic).

  The problem is I have no way to capture the logs when the computer
  freezes... so I have no more details to debug where the issue actually
  comes from. My guess were the graphical drivers; I tried xserver-xorg-
  video-intel both the official version and the PPA
  (2.99.917+git20151202.da9ad388-0ubuntu0sarvatt) with the same result.

To manage notifications about this bug go to: