← Back to team overview

kernel-packages team mailing list archive

[Bug 1560835] Re: Enable multitouch function on precision touchpad for Vivid


This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

** Tags added: verification-needed-vivid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Enable multitouch function on precision touchpad for Vivid

Status in HWE Next:
Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Vivid:
  Fix Committed
Status in linux source package in Wily:
  In Progress
Status in linux source package in Xenial:
  Fix Released

Bug description:

  Multitouch feature is not enabled on some platforms with new Win8
  precision touchpad because it can't fetch the report from the device.
  In worst case it can even break the multitouch device.


  There's one commit to fix this issue:
  commit 171202b6fee80d777d18bb8a53b3e4361d97f389
  Author: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx>
  Date:   Wed Oct 7 15:33:43 2015 +0300

      HID: multitouch: Fetch feature reports on demand for Win8 devices

  In addition, this commit may cause some issue on ELAN touchpad, and
  there's another commit to improve the fix:

  commit e47b1e449ea70d76c38a50c04cde60a72bc7ebde
  Author: Benjamin Tissoires <benjamin.tissoires@xxxxxxxxxx>
  Date:   Tue Dec 1 12:41:38 2015 +0100

      HID: multitouch: fix input mode switching on some Elan panels

  Both commits can be clean picked, and are already in Xenial.


  The patched Vivid kernel is tested on two platforms and both worked
  before and after suspend.

To manage notifications about this bug go to: