← Back to team overview

kernel-packages team mailing list archive

[Bug 1438510] Re: [REGRESSION] bluetooth headset no longer supports a2dp


I can confirm that ubuntu 16.04 LTS is exhibiting this behavior with
three separate bluetooth headsets (JABRA REVO 2.0, Sony MDRXB950BT, and
Sennheiser Urbanite XL WIreless).

14.04, 14.10, 15.04, and 15.10 all worked quite well with no additional
configuration necessary. By "worked quite well" I mean I could pair all
three headsets, they would remain paired through reboots, and I could
get A2DP output from each.

On 16.04, in both gnome and unity, it is a hit or miss affair of pairing
any of these headsets. I have a Dell XPS 15 and had zero problems prior
to installing 16.04.

I used the procedure in post #5, but that does not persist after
reboots. I have to unpair the headset completely and then repair in
order to get sound. Even then it's hit or miss, sometimes it doesn't

I'd be happy to give more details to help resolve this.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  [REGRESSION] bluetooth headset no longer supports a2dp

Status in bluez package in Ubuntu:
Status in pulseaudio package in Ubuntu:
Status in bluez source package in Vivid:
Status in pulseaudio source package in Vivid:

Bug description:
  Just installed 15.04 fresh from the latest ISO (beta2).

  I'm bummed to see my bluetooth headset (Bose Soundlink overear) seems
  to have regressed in functionality.

  In 14.10, I was able to set the output profile either to a2dp or
  hsp/hfp (telephony duplex).

  In 15.04, it only works in telephony duplex mode.  I can't get high
  fidelity sound playback to work at all.

  This thread seems to be related, though the workaround within did not solve the problem for me:

To manage notifications about this bug go to: