← Back to team overview

kernel-packages team mailing list archive

[Bug 1575334] Re: Docking thinkpad laptop causes a complete system freeze


I've tried the kernel in -proposed, with the same results as above:



I've also tried to get a crash dump by following the commands listed at:
https://help.ubuntu.com/16.04/serverguide/kernel-crash-dump.html but so
far without success.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Docking thinkpad laptop causes a complete system freeze

Status in linux package in Ubuntu:

Bug description:
  Since upgrading to Xenial, about 80% of the time when I dock my
  thinkpad laptop I get a complete system freeze. The symptoms of the
  freeze are:

   * The two external monitors connected to the dock seem to be in a
  half-configured state - they're powered on, and display some graphics
  from my desktop, but do not yet show the correct contents.

   * I can't get to a console with Ctrl+Alt+F1.

   * I can't kill X with Ctrl+Alt+Backspace

   * I can't get the mouse cursor to appear or move, either with the
  trackpad or the external mouse.

   * Undocking the laptop doesn't help.

  The only thing I *can* do at this point is to hold down the power

  I seem to recall similar issues in the past (perhaps in Vivid?), where
  the fix ended up being in the graphics driver.

  The laptop is a T540p. The docking station is an "ultra dock pro" -
  not a USB dock, but rather one of those ones where the laoptop clicks
  into a base.

  This bug makes the docking station rather useless, and makes me sad :(

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-21-generic 4.4.0-21.37
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC2:  thomi      3196 F.... pulseaudio
   /dev/snd/controlC0:  thomi      3196 F.... pulseaudio
   /dev/snd/controlC1:  thomi      3196 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Wed Apr 27 07:35:58 2016
  HibernationDevice: RESUME=UUID=d27c9b15-955a-4bff-b4a7-e6116a8b30bb
  InstallationDate: Installed on 2015-10-12 (197 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: LENOVO 20BECTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-21-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-04-21 (5 days ago)
  dmi.bios.date: 09/01/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: GMET72WW (2.20 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20BECTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40709 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvrGMET72WW(2.20):bd09/01/2015:svnLENOVO:pn20BECTO1WW:pvrThinkPadT540p:rvnLENOVO:rn20BECTO1WW:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 20BECTO1WW
  dmi.product.version: ThinkPad T540p
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: