← Back to team overview

kernel-packages team mailing list archive

[Bug 1577113] Re: 50/50 chance for BCM43602 to come up correctly during boot


I believe this is similar to the issue im getting with my BCM43602 on
macbookpro running 16.04. It worked fine on 15.10.

Ive updated to the upstream xenial kernel but the bug still exists :

$uname -a
Linux <redacted> 4.4.9-040409-generic #201605041832 SMP Wed May 4 22:34:16 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$lspci | grep -i wire
03:00.0 Network controller: Broadcom Corporation BCM43602 802.11ac Wireless LAN SoC (rev 01)

$dmesg | grep -i brcmf
[   10.242291] usbcore: registered new interface driver brcmfmac
[   10.381196] brcmfmac 0000:03:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.txt failed with error -2
[   10.864481] brcmf_c_preinit_dcmds: Firmware version = wl0: Nov 10 2015 06:38:10 version (r598657) FWID 01-ea662a8c
[   10.892497] brcmf_cfg80211_reg_notifier: not a ISO3166 code
[   10.897532] brcmfmac 0000:03:00.0 wlp3s0: renamed from wlan0
[   10.968018] brcmf_add_if: ERROR: netdev:wlp3s0 already exists
[   10.968051] brcmf_add_if: ignore IF event
[   11.080205] brcmf_add_if: ERROR: netdev:wlp3s0 already exists
[   11.080208] brcmf_add_if: ignore IF event

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  50/50 chance for BCM43602 to come up correctly during boot

Status in linux package in Ubuntu:

Bug description:
  My BCM43602 has a 50/50 chance during boot of ever becoming "ready"
  and pulling an IP address. The problem seems to be this "link is not
  ready" and "already exists" loop. The log I sent was one of the cases
  where things eventually worked. If I get unlucky, it simply repeats
  the "already exists" / "not ready" loop indefinitely.

  I get a similar situation when suspending/resuming. I've already
  pulled the firmware and stuck it under /lib (see dmesg output for

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-21-generic 4.4.0-21.37 [modified: boot/vmlinuz-4.4.0-21-generic]
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  greg.taylor   2418 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sun May  1 01:11:42 2016
  HibernationDevice: RESUME=UUID=efd205da-4a67-4d8a-9c0e-6f3036178157
  InstallationDate: Installed on 2016-04-28 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 002: ID 0a5c:6410 Broadcom Corp. 
   Bus 001 Device 003: ID 0c45:6713 Microdia 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. XPS 15 9550
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-21-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/07/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.02.00
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A01
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA01:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: