← Back to team overview

kernel-packages team mailing list archive

[Bug 1580776] Re: Kernel Oops - unable to handle kernel NULL pointer dereference at 0000000000000002; IP is at mmc_ioctl_cdrom_read_audio+0x212/0x3b0


Tested with reading 25 frames per ioctl and the freeze happens at
roughly the same frame region.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Kernel Oops - unable to handle kernel NULL pointer dereference at
  0000000000000002; IP is at  mmc_ioctl_cdrom_read_audio+0x212/0x3b0

Status in linux package in Ubuntu:

Bug description:
  While playing around with the CDROM API found in linux/cdrom.h I
  encountered a kernel oops when my program stalls.  My code can be
  found at https://github.com/bigdavedev/audiorip.

  My program simply examines the ToC and then begins reading the PCM
  data track-by-track.  I would expect it to complete without any major

  At first I assumed it was the CD, but after switching CDs several
  times I noticed that the oops happens at around frame 170925, reading
  CD_FRAMES (75) per ioctl.  At this point, the disc is spinning at full
  speed.  I have not yet tried reading fewer frames, nor have I tried
  setting the speed to something not max to see if I still receive a
  kernel oops.  This would not be problematic to try.

  I have attached the output from `ubuntu-bug linux` to this issue.
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  dabr       2430 F.... pulseaudio
  DistroRelease: Ubuntu 16.04
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-01-29 (102 days ago)
  InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-22-generic.efi.signed root=/dev/mapper/primary_lvm_volume-root ro
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
   linux-restricted-modules-4.4.0-22-generic N/A
   linux-backports-modules-4.4.0-22-generic  N/A
   linux-firmware                            1.157
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  xenial
  Uname: Linux 4.4.0-22-generic x86_64
  UpgradeStatus: Upgraded to xenial on 2016-04-19 (22 days ago)
  UserGroups: adm audio bumblebee cdrom dialout dip kvm lpadmin plugdev sambashare sudo video
  _MarkForUpload: True
  dmi.bios.date: 03/11/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: K55VD.411
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: K55VD
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK55VD.411:bd03/11/2013:svnASUSTeKCOMPUTERINC.:pnK55VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK55VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: K55VD
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: