← Back to team overview

kernel-packages team mailing list archive

[Bug 1583288] Re: Realtek Wifi card rtl8723be [10ec:b723] WiFi not available [SOLVED]


Hi Brad,

I cannot run any scripts nor I can I test any new kernels right now
because I was configuring these two laptops for friends. I do not own
any of them myself but if I find the time I will try to give response to
any question. I will then first upgrade to the newest kernel (4.6) then
check and report back here. Thanks for all your time and help!!!


** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Realtek Wifi card rtl8723be [10ec:b723] WiFi not available [SOLVED]

Status in linux package in Ubuntu:

Bug description:
  I am here on a HP Pavilion Laptop with beatsaudio. No Model Number -
  nothing.But I have this problem on other HP (455) Notebooks too.

  OS tried: OpenSuse / Kubuntu / Linux Mint Mate (card does not work out
  of the box / no scanning)

  The Wifi card is: (in Germany!)


   lspci -nn | grep -iA2 net
  02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]


  I am now under kernel:

  I installed the newest kernel because in some threads people said the card woule be available in the newest kernel. But this was not the case. I mean the card is there but does not scan nor see any wifi networks.

  Before I tried everything I could find to get my wifi running but I do
  not even see one spot. So no connection at all. I even cloned git and
  compiled the driver - the compiling and installation worked fine. I
  tried the old and the new driver.

  By the way the BT seems to be fine - although I have not checked cause
  I do not need BT.

  Here is what I tried:

  rfkill list all; hciconfig -a
  0: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
  1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
  hci0: Type: BR/EDR Bus: USB
   BD Address: 2C:33:7A:3F:E4:3E ACL MTU: 820:8 SCO MTU: 255:16
   RX bytes:1327 acl:0 sco:0 events:139 errors:0
   TX bytes:25058 acl:0 sco:0 commands:139 errors:0
   Features: 0xff 0xff 0xff 0xfe 0xdb 0xff 0x7b 0x87
   Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
   Link mode: SLAVE ACCEPT
   Name: 'mint-0'
   Class: 0x740100
   Service Classes: Rendering, Object Transfer, Audio, Telephony
   Device Class: Computer, Uncategorized
   HCI Version: 4.0 (0x6) Revision: 0xe2f
   LMP Version: 4.0 (0x6) Subversion: 0x9f73
   Manufacturer: Realtek Semiconductor Corporation (93)


  I added the options sugested in rtl8723be.conf

  options rtl8723be fwlps=0 swlps=0

  But this did not help either.


  lsmod reports:

  rfcomm 69632 12
  rtl8723be 139264 0
  btcoexist 180224 1 rtl8723be
  rtl_pci 40960 1 rtl8723be
  rtlwifi 98304 3 btcoexist,rtl_pci,rtl8723be
  hp_wmi 16384 0
  mac80211 733184 3 rtl_pci,rtlwifi,rtl8723be
  sparse_keymap 16384 1 hp_wmi
  kvm 532480 0
  irqbypass 16384 1 kvm
  btusb 45056 0
  crct10dif_pclmul 16384 0
  btrtl 16384 1 btusb
  btbcm 16384 1 btusb


  dmesg | grep rtl reports:

  [ 8.982260] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
  [ 8.982262] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
  [ 9.064265] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
  [ 9.403770] Using firmware rtlwifi/rtl8723befw.bin
  [ 9.404023] rtlwifi: channel plan 0x20
  [ 9.404027] rtlwifi: country code 11
  [ 9.422483] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
  [ 9.423458] rtlwifi: wireless switch is on


  modinfo rtl8723be

  filename: /lib/modules/4.4.0-21-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
  firmware: rtlwifi/rtl8723befw.bin
  description: Realtek 8723BE 802.11n PCI wireless
  license: GPL
  author: Realtek WlanFAE <wlanfae@xxxxxxxxxxx>
  author: PageHe <page_he@xxxxxxxxxxxxxx>
  srcversion: 00619764255210776FAB54D
  alias: pci:v000010ECd0000B723sv*sd*bc*sc*i*
  depends: rtlwifi,rtl_pci,btcoexist,mac80211
  vermagic: 4.4.0-21-generic SMP mod_unload modversions
  parm: swlps:bool
  parm: swenc:using hardware crypto (default 0 [hardware])
  parm: ips:using no link power save (default 1 is open)
  parm: fwlps:using linked fw control power save (default 1 is open)
  parm: msi:Set to 1 to use MSI interrupts mode (default 0)
  parm: debug:Set debug level (0-5) (default 0) (int)
  parm: disable_watchdog:Set to 1 to disable the watchdog (default 0)
  parm: ant_sel:Set to 1 or 2 to force antenna number (default 0)


  sudo iwlist scan

  wlan0 No scan results


  sudo iwconfig
  eth0 no wireless extensions.

  wlan0 IEEE 802.11bgn ESSID:off/any
            Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
            Retry short limit:7 RTS thr=2347 B Fragment thr:off
            Encryption key:off
            Power Management:off

  lo no wireless extensions.


  sudo ifconfig wlan0 down
  sudo ifconfig wlan0 up

  without errors.


  In my disappointment I tried this:

  From https://bugzilla.kernel.org/show_bug.cgi?id=83641#c1

  "There is a new version of this driver at GitHub. You will need to
  have the package with the kernel headers installed.

  git clone http://github.com/lwfinger/rtlwifi_new.git
  cd rtlwifi_new
  sudo make install

  This version of the driver will be submitted for inclusion in kernel
  3.18. I ran it for 39 hours with no disconnects."


  no errors but no change.


  Checked this link:



  Then I tried several params and finally this worked somehow.

  sudo modprobe -rv rtl8723be

  sudo modprobe -v rtl8723be msi=1

  I now was able to see wifi networks - hoorayyyy!! :)


  I then tried to connect to my network - but failed.

  I am sitting 1 m next to my router.


  [ 2027.454666] AMD-Vi: Event logged [INVALID_DEVICE_REQUEST device=00:00.1 address=0x000000fdf8080020 flags=0x0a00]
  [ 2027.464903] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
  [ 2051.922688] cfg80211: World regulatory domain updated:
  [ 2051.922698] cfg80211: DFS Master region: unset
  [ 2051.922701] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
  [ 2051.922709] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
  [ 2051.922714] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
  [ 2051.922719] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
  [ 2051.922723] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
  [ 2051.922727] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
  [ 2051.963665] Using firmware rtlwifi/rtl8723befw.bin
  [ 2051.963841] rtlwifi: channel plan 0x20
  [ 2051.963845] rtlwifi: country code 11
  [ 2051.965731] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
  [ 2051.966606] rtlwifi: wireless switch is on
  [ 2052.401828] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
  [ 2221.380867] r8169 0000:03:00.0 eth0: link down
  [ 2229.644057] systemd-hostnamed[3082]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
  [ 2254.504927] wlan0: authenticate with 58:7f:66:65:73:6c
  [ 2254.933657] wlan0: send auth to 58:7f:66:65:73:6c (try 1/3)
  [ 2256.065621] wlan0: send auth to 58:7f:66:65:73:6c (try 2/3)
  [ 2257.065727] wlan0: send auth to 58:7f:66:65:73:6c (try 3/3)
  [ 2258.089758] wlan0: authentication with 58:7f:66:65:73:6c timed out


  Then I changed region to Germany:

  echo 'KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform",
  RUN+="/sbin/iw reg set DE"' | sudo tee

  and then I was able to connect. My options are now:

  options rtl8723be fwlps=0 swlps=0 msi=1

  Now it runs perfectly! Thanks to all!!

To manage notifications about this bug go to: