← Back to team overview

kernel-packages team mailing list archive

[Bug 1584471] [NEW] Java threads produce OutOfMemoryError with 4.4.0-22 kernel


You have been subscribed to a public bug:

Hi all.

I am running Ubuntu 16.04 (through regular updates and upgrades) on an
HP DL380 with dual hex-core Xeon 3.47GHz cpus and 96GB RAM.

I upgraded this system a week ago, and started getting Java
OutOfMemoryErrors (unable to create new native thread) from Wowza
Streaming Engine. I tried older versions of Java (7 and 6 oracle
versions) and they improved it, but did not fix it.

When I stopped the Wowza service from the command line, the service
command would hang until I killed the java process.

I booted my system into the 3.16.0-41 kernel that was still there, and
everything works as it should (no more OutOfMemoryErrors). I have not
tried the 3.16 kernel with Java 8 OpenJDK; it is still running on Java

Did something change drastically with the thread modules between the
3.16.0 kernel and the 4.4.0 kernel?

Wowza starts Java with the -Xmx10000M option.

One of the log entries for this error is:

WARN    server  comment 2016-05-20      23:55:21        -       -
-       --5405.152        -       -       -       -       -       -
-       -       Unexpected exception.: java.lang.OutOfMemoryError:
unable to create new native thread|at java.lang.Thread.start0(Native
Method)|at java.lang.Thread.start(Thread.java:714)|at


** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: bot-comment
Java threads produce OutOfMemoryError with 4.4.0-22 kernel
You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-meta in Ubuntu.