← Back to team overview

kernel-packages team mailing list archive

[Bug 1584471] Re: Java threads produce OutOfMemoryError with 4.4.0-22 kernel


Would it be more helpful to run apport-collect with the 4.4.0-22 kernel
running after the OutOfMemoryError has occurred?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Java threads produce OutOfMemoryError with 4.4.0-22 kernel

Status in linux package in Ubuntu:

Bug description:
  Hi all.

  I am running Ubuntu 16.04 (through regular updates and upgrades) on an
  HP DL380 with dual hex-core Xeon 3.47GHz cpus and 96GB RAM.

  I upgraded this system a week ago, and started getting Java
  OutOfMemoryErrors (unable to create new native thread) from Wowza
  Streaming Engine. I tried older versions of Java (7 and 6 oracle
  versions) and they improved it, but did not fix it.

  When I stopped the Wowza service from the command line, the service
  command would hang until I killed the java process.

  I booted my system into the 3.16.0-41 kernel that was still there, and
  everything works as it should (no more OutOfMemoryErrors). I have not
  tried the 3.16 kernel with Java 8 OpenJDK; it is still running on Java

  Did something change drastically with the thread modules between the
  3.16.0 kernel and the 4.4.0 kernel?

  Wowza starts Java with the -Xmx10000M option.

  One of the log entries for this error is:

  WARN    server  comment 2016-05-20      23:55:21        -       -
  -       --5405.152        -       -       -       -       -       -
  -       -       Unexpected exception.: java.lang.OutOfMemoryError:
  unable to create new native thread|at java.lang.Thread.start0(Native
  Method)|at java.lang.Thread.start(Thread.java:714)|at

   total 0
   crw-rw---- 1 root audio 116,  1 May 21 16:44 seq
   crw-rw---- 1 root audio 116, 33 May 21 16:44 timer
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  DistroRelease: Ubuntu 16.04
  HibernationDevice: RESUME=/dev/mapper/media--vg-swap_1
  InstallationDate: Installed on 2015-04-08 (411 days ago)
  InstallationMedia: Ubuntu-Server 14.10 "Utopic Unicorn" - Release amd64 (20141022.2)
  MachineType: HP ProLiant DL380 G7
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-41-generic root=/dev/mapper/hostname--vg-root ro
  ProcVersionSignature: Ubuntu 3.16.0-41.57-generic 3.16.7-ckt11
   linux-restricted-modules-3.16.0-41-generic N/A
   linux-backports-modules-3.16.0-41-generic  N/A
   linux-firmware                             1.157
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  xenial
  Uname: Linux 3.16.0-41-generic x86_64
  UpgradeStatus: Upgraded to xenial on 2016-05-14 (9 days ago)
  _MarkForUpload: True
  dmi.bios.date: 07/02/2013
  dmi.bios.vendor: HP
  dmi.bios.version: P67
  dmi.chassis.type: 23
  dmi.chassis.vendor: HP
  dmi.modalias: dmi:bvnHP:bvrP67:bd07/02/2013:svnHP:pnProLiantDL380G7:pvr:cvnHP:ct23:cvr:
  dmi.product.name: ProLiant DL380 G7
  dmi.sys.vendor: HP

To manage notifications about this bug go to: