← Back to team overview

kernel-packages team mailing list archive

[Bug 912397] Re: Intel HD Graphics "No Device Detected"


This bug report may be closed, but the bug itself definitely is not. I
just installed Xubuntu 16.04, and of course I was stuck with black
screen until I added "nomodeset" to grub (as I've done with the past 10+
versions of Ubuntu). Unfortunately, this time my max resolution is
1024x758, and those ar  the few times I can get past boot.

Evidently this has something to do with X being taken out of the loop as
far as loading the video drivers... correct? The kernel does this now,
but seems to do it very badly. Anyway to reopen this?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Intel HD Graphics "No Device Detected"

Status in Linux:
  Fix Released
Status in linux package in Ubuntu:

Bug description:
  Intel HD Graphics is not recognized by kernel Other kernels I've tried on Ubuntu 11.10:

  All of them must be started with "nomodeset". If this is not done, I get a black screen. With nomodeset the display can run at 1280x1024, with vesa driver. It's a full HD display and is supposed to run at 1920x1080.
  With "nomodeset" and with a xorg.conf using "intel" driver, when X starts I get "no device detected" error, falling back to console.

  I've tried lastest version of other distros with the same result: OpenSUSE 12.1, Fedora 16, Bodhi 1.3, Ubuntu Precise 12.04 alpha, 
  CentOS 6.2, Extix 9, and i don't remember if anyone else.

  I've tried too the 3.2 rc4 and rc7 kernel on Ubuntu 11.10, and those
  works better: nomodeset is not needed and I get full 1920x1080
  resolution, but it's very unstable because the video turns off and on
  constantly (or turns into black), about 5 seconds each.

  I've read in a lot of forums that the Intel HD Graphics are supported
  since 2.6.3x kernel, and must work ok too with 3.x, but it is failing
  with this specification.

  Even I tried the http://ppa.launchpad.net/glasen/intel-driver as
  suggested in several forums.

  cat /proc/version_signature  ---> Ubuntu 3.0.0-14.23-generic 3.0.9

  sudo lspci -vk
  00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
  	Subsystem: Dell Device 0511
  	Flags: bus master, fast devsel, latency 0, IRQ 46
  	Memory at fe000000 (64-bit, non-prefetchable) [size=4M]
  	Memory at d0000000 (64-bit, prefetchable) [size=256M]
  	I/O ports at f000 [size=64]
  	Expansion ROM at <unassigned> [disabled]
  	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
  	Capabilities: [d0] Power Management version 2
  	Capabilities: [a4] PCI Advanced Features
  	Kernel modules: i915

  sudo lshw -C video
    *-display UNCLAIMED     
         description: VGA compatible controller
         product: 2nd Generation Core Processor Family Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list
         configuration: latency=0
         resources: memory:fe000000-fe3fffff memory:d0000000-dfffffff ioport:f000(size=64)

  The machine is a DELL INSPIRON ALL IN ONE 2320 i3 2100 CPU

  One post to have a read is: http://www.grputland.com/2011/12/ubuntu-1204-alpha-1-sandy-bridge.html
  It is the same problem as I describe it here.


  ProblemType: Bug
  DistroRelease: Ubuntu 11.10
  Package: linux-image-3.0.0-14-generic 3.0.0-14.23
  ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
  Uname: Linux 3.0.0-14-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
   **** List of PLAYBACK Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: ALC269 Analog [ALC269 Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
  ApportVersion: 1.23-0ubuntu4
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: ALC269 Analog [ALC269 Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  gspadari   1751 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'PCH'/'HDA Intel PCH at 0xfe500000 irq 47'
     Mixer name	: 'Realtek ALC269'
     Components	: 'HDA:10ec0269,10280511,00100202'
     Controls      : 14
     Simple ctrls  : 10
  Date: Thu Jan  5 13:42:39 2012
  HibernationDevice: RESUME=UUID=d472e32e-08ee-4a81-a4d6-d546e293ca74
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  MachineType: Dell Inc. Inspiron One 2320
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=27b16ee7-81be-4a30-9fe2-4b0ebaeb379d ro quiet splash i915.i915_enable_rc6=1 nomodeset acpi_osi=Linux vt.handoff=7
   linux-restricted-modules-3.0.0-14-generic N/A
   linux-backports-modules-3.0.0-14-generic  N/A
   linux-firmware                            1.60
  SourcePackage: linux
  StagingDrivers: rts5139 mei
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/22/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A06
  dmi.board.name: 03KPVW
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 13
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 20147321890_1
  dmi.modalias: dmi:bvnDellInc.:bvrA06:bd12/22/2011:svnDellInc.:pnInspironOne2320:pvr00:rvnDellInc.:rn03KPVW:rvrA00:cvnDellInc.:ct13:cvr20147321890_1:
  dmi.product.name: Inspiron One 2320
  dmi.product.version: 00
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: