← Back to team overview

kernel-packages team mailing list archive

[Bug 1567316] Re: CPU maximum frequency goes down after every resume


Erik van Linstee, this bug report is being closed due to your last
regarding this being fixed with an update. For future reference you can
manage the status of your own bugs by clicking on the current status in
the yellow line and then choosing a new status in the revealed drop down
box. You can learn more about bug statuses at
https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time
to report this bug and helping to make Ubuntu better. Please submit any
future bugs you may find.

** Tags added: bios-outdated-9dcn34ww

** Changed in: linux (Ubuntu)
       Status: Incomplete => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  CPU maximum frequency goes down after every resume

Status in linux package in Ubuntu:

Bug description:
  This bug applies to Ubuntu 15.10, kernel 4.2.0-35-generic and at least
  two before that.

  A while ago I noticed that my system had become unbearably slow. A reboot fixed it for a while.
  It turns out that the problem is related to resuming after closing the laptop lid. After every resume the CPU maximum frequency goes down a bit.

  This was not always the case and seems to have been introduced after a
  kernel update. Sadly, I can't pinpoint which one exactly.

  It can be reproduced on my Lenovo B50-70 even after the latest kernel
  update to 4.2.0-35-generic of Ubuntu 15.10.

  I start by rebooting the system.
  At first, 'sudo cpupower frequency-info' reports a hardware limit of 800 MHz - 2.60 GHz and current policy is between those two.
  Current frequency varies between those based on load.
  Now, I close the lid, reopen and check again.
  Hardware limits are still the same, but policy is now between 800 MHz and 2.08 GHz.
  Repeat and policies maximum keeps dropping. As does the current frequency maximum.
  At some point the policy maximum does not drop any further, but the current frequency maximum does. Way below even the minimum of 800 MHz.

  The expected behaviour is that the current policy matches the hardware
  limits and that the CPU frequency is set between these values.

  Here is the output of 'sudo cpupower frequency-info' after the first

  analyzing CPU 0:
    driver: intel_pstate
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 0.97 ms.
    hardware limits: 800 MHz - 2.60 GHz
    available cpufreq governors: performance, powersave
    current policy: frequency should be within 800 MHz and 2.08 GHz.
                    The governor "powersave" may decide which speed to use
                    within this range.
    current CPU frequency is 1.03 GHz (asserted by call to hardware).
    boost state support:
      Supported: yes
      Active: yes
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
   /dev/snd/pcmC1D0p:   erik       1692 F...m pulseaudio
   /dev/snd/controlC1:  erik       1692 F.... pulseaudio
   /dev/snd/controlC0:  erik       1692 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 15.10
  HibernationDevice: RESUME=UUID=e15f518b-0603-40f2-91f8-a715860f726e
  InstallationDate: Installed on 2015-08-12 (240 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
   No journal files were found.
   -- No entries --
  MachineType: LENOVO 80EU
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-35-generic.efi.signed root=UUID=d8909dac-cfa5-4a3e-ac20-e5f1e8b01609 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.2.0-35.40-generic 4.2.8-ckt5
   linux-restricted-modules-4.2.0-35-generic N/A
   linux-backports-modules-4.2.0-35-generic  N/A
   linux-firmware                            1.149.3
  Tags:  wily
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  Uname: Linux 4.2.0-35-generic x86_64
  UpgradeStatus: Upgraded to wily on 2015-10-25 (165 days ago)
  UserGroups: dialout sudo wireshark
  _MarkForUpload: True
  dmi.bios.date: 08/21/2014
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 9DCN22WW(V2.03)
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Lenovo B50-70
  dmi.board.vendor: LENOVO
  dmi.board.version: 31900058WIN
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo B50-70
  dmi.modalias: dmi:bvnLENOVO:bvr9DCN22WW(V2.03):bd08/21/2014:svnLENOVO:pn80EU:pvrLenovoB50-70:rvnLENOVO:rnLenovoB50-70:rvr31900058WIN:cvnLENOVO:ct10:cvrLenovoB50-70:
  dmi.product.name: 80EU
  dmi.product.version: Lenovo B50-70
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: