← Back to team overview

kernel-packages team mailing list archive

[Bug 1565864] Re: Hardware-specific: Fan is running at full speed on resume


I've updated BIOS to the latest 1301, still no luck, fan still running
at full speed after resume. Nothing new.

dmidecode output:
$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Hardware-specific: Fan is running at full speed on resume

Status in linux package in Ubuntu:

Bug description:
  This bug is related to Asus 1025C laptop.
  Steps to reproduce:

  1) Boot into Ubuntu
  2) run pm-suspend
  3) Wake up the laptop

  After a few seconds the CPU fan spins up to max speed and it doesn't slow down until reboot/poweroff.
  Hibernation can also fix this, so, fan runs at normal speed.
  It is not a PWM fan, so, I guess, I can't control it via /sys.

  Output of "sensors" before suspend:
  Adapter: Virtual device
  temp1:        +55.0°C  (crit = +255.0°C)

  Adapter: Virtual device
  temp1:        +0.0°C  (crit = +255.0°C)

  I've had a Linux Mint 17 before Ubuntu 15.10. No issues were in Mint. Before Mint, I've used a Kubuntu 14.04, 14.10, no issues either.
  I've tried to compile old versions of linux kernel (from the official git repo) and I noticed, that 3.16 kernel was the latest, where fan works properly. 3.17-rc1 breaks it.

  According to git commit history, 3.17 kernel have many commits related
  to ACPI/PM fixes.

  My guess is that kernel doesn't restore thermal sensor device from
  sleep properly since 3.17.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-34-generic 4.2.0-34.39
  ProcVersionSignature: Ubuntu 4.2.0-34.39-generic 4.2.8-ckt4
  Uname: Linux 4.2.0-34-generic i686
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: i386
   /dev/snd/controlC0:  raxp       1809 F.... pulseaudio
  CurrentDesktop: MATE
  Date: Mon Apr  4 17:17:13 2016
  HibernationDevice: RESUME=UUID=31cbf4f8-c9b4-4025-b1fd-d5f474861585
  InstallationDate: Installed on 2016-03-16 (19 days ago)
  InstallationMedia: Ubuntu-MATE 15.10 "Wily Werewolf" - Release i386 (20151021)
  MachineType: ASUSTeK COMPUTER INC. 1025C
  ProcFB: 0 psbdrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-34-generic root=UUID=98d65d26-361a-4e60-80e4-7b63d31d1ec6 ro quiet splash vt.handoff=7
   linux-restricted-modules-4.2.0-34-generic N/A
   linux-backports-modules-4.2.0-34-generic  N/A
   linux-firmware                            1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/16/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1025C.1001
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: 1025C
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: x.xx
  dmi.chassis.asset.tag: 0x00000000
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: x.x
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1025C.1001:bd04/16/2012:svnASUSTeKCOMPUTERINC.:pn1025C:pvrx.x:rvnASUSTeKCOMPUTERINC.:rn1025C:rvrx.xx:cvnASUSTeKCOMPUTERINC.:ct10:cvrx.x:
  dmi.product.name: 1025C
  dmi.product.version: x.x
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: