← Back to team overview

kernel-packages team mailing list archive

[Bug 1388786] Re: TCP stale transfer with erroneous SACK information


I can reproduce this error too.
The environment is a full CISCO network with vmware ESXi hosts and ubuntu 14.04 guests.

Also here downloads to about 2MB are going somehow fine, but all which
is taking longer (or more MB to transfer) is dropping to a very low
bandwidth. Very often without any bits transmitted at all.

The issue is, that it looks like if pakets are received in random (not
serial order) the SACK seems to be too aggressive and kicks the high
speed of the transmission

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  TCP stale transfer with erroneous SACK information

Status in linux package in Ubuntu:
  In Progress

Bug description:
  Cisco PIX/FWSM changes TCP sequence numbers but doesn't change numbers
  in SACK TCP options.

  When this erroneous information comes to Linux server there is some
  corruption in TCP stack in some circunstances with CUBIC TCP
  congestion algorithm and transfer stales.

  Problem can be reproduced in Ubuntu Server 14.04 when a Cisco FWSM is
  changing sequence numbers (default configuration) and a big file
  (30MB, for example) is being transfered.

  Can be solved deactivating SACK:
  sysctl -w net.ipv4.tcp_sack=0

  We have solved it also with this configuration:
  sysctl -w net.ipv4.tcp_congestion_control=reno
  sysctl -w net.ipv4.tcp_frto=1
  sysctl -w net.ipv4.tcp_early_retrans=1

  We can also fix  it by changing firewall configuration.

  Find attached a wireshark capture where you can see at 16613 frame how
  client requests segment 853521869 and server ( resends
  again a previous segment for 87 seconds until it stops transfer.


To manage notifications about this bug go to: