← Back to team overview

kernel-packages team mailing list archive

[Bug 1586630] Re: Wireless card QCA6164 crashes when booting


I'll gladly help with this, but I don't know how to revert to the old
ubuntu firmeware.

When I tried to do sudo dpkg -r linux-firmware_1.158_all.deb

I got this error:
dpkg: error: you must specify packages by their own names, not by quoting the names of the files they come in

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or
'more' !

And I have no clue which package that did the trick so I don't know
which to uninstall if it aint possible to uninstall the whole .deb

If you know a way please tell me and I'll do it.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Wireless card QCA6164 crashes when booting

Status in linux package in Ubuntu:

Bug description:
  I've been trying to get my Qualcomm Atheros QCA6164 (168:0041 rev20)
  to work with diffrent firmwares without success. I've been testing
  Kalle Valos and atondvals firmware with no luck. Kalle Valos firmware
  enables wifi over 2,4GHz only, and not on every router for me. Last
  night I tried the new linux-firmwaren from:


  That didn't work either.

  I did install it, rebooted only to see the WiFi icon flash, so I tried
  "systemctl restart NetworkManager.service" just to see the WiFiicon
  falsh again and then the networkmanager crashed compleatly. so I ran
  the command again to get it back up but still no WiFi.

  Here is the dmesg for the ath10k

  [   16.553380] ath10k_pci 0000:02:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
  [   17.034061] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
  [   17.617966] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board-2.bin failed with error -2
  [   18.904246] ath10k_pci 0000:02:00.0: firmware crashed! (uuid 760b80fd-a2fb-4e90-a668-21cdeedd1d2b)
  [   18.904257] ath10k_pci 0000:02:00.0: qca6164 hw2.1 (0x05010000, 0x003405ff sub 17aa:3545) fw WLAN.RM.1.1-00141 fwapi 5 bdapi 1 htt-ver 0.0 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp,no-4addr-pad
  [   18.904261] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
  [   18.905365] ath10k_pci 0000:02:00.0: firmware register dump:
  [   18.905369] ath10k_pci 0000:02:00.0: [00]: 0x05010000 0x000015B3 0x000A012D 0x00955B31
  [   18.905373] ath10k_pci 0000:02:00.0: [04]: 0x000A012D 0x00060330 0x00000016 0x83785006
  [   18.905376] ath10k_pci 0000:02:00.0: [08]: 0x00000000 0x00400000 0x00400600 0x00000001
  [   18.905379] ath10k_pci 0000:02:00.0: [12]: 0x00000009 0x00000000 0x00931C61 0x00931C7D
  [   18.905382] ath10k_pci 0000:02:00.0: [16]: 0x0096BDBC 0x009287BD 0x00000000 0x00000000
  [   18.905385] ath10k_pci 0000:02:00.0: [20]: 0x400A012D 0x0040E2B0 0x00955A00 0x00404590
  [   18.905387] ath10k_pci 0000:02:00.0: [24]: 0x809287D9 0x0040E310 0x7A5087F8 0xC00A012D
  [   18.905390] ath10k_pci 0000:02:00.0: [28]: 0x809288D7 0x0040E340 0x00000000 0xFFF08040
  [   18.905393] ath10k_pci 0000:02:00.0: [32]: 0x809290FE 0x0040E360 0x00400000 0x00400600
  [   18.905395] ath10k_pci 0000:02:00.0: [36]: 0x80929205 0x0040E380 0x00000000 0x00400600
  [   18.905398] ath10k_pci 0000:02:00.0: [40]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0
  [   18.905401] ath10k_pci 0000:02:00.0: [44]: 0x00000000 0x0040E3D0 0x009BB001 0x00040020
  [   18.905403] ath10k_pci 0000:02:00.0: [48]: 0x00401BF0 0x00000001 0x00404B9C 0x00400000
  [   18.905406] ath10k_pci 0000:02:00.0: [52]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0
  [   18.905409] ath10k_pci 0000:02:00.0: [56]: 0xA373B200 0x3D61F660 0x05620156 0x0C677F60
  [   19.902111] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling..
  [   20.901952] ath10k_pci 0000:02:00.0: ctl_resp never came in (-110)
  [   20.901972] ath10k_pci 0000:02:00.0: failed to connect to HTC: -110
  [   20.978482] ath10k_pci 0000:02:00.0: could not init core (-110)
  [   20.978513] ath10k_pci 0000:02:00.0: could not probe fw (-110)
  [   21.878061] ath10k_pci 0000:02:00.0: cannot restart a device that hasn't been started

  An update for this card would be nice :) I'll gladly help testing it
  and see if you provide instructions.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-firmware 1.157
  ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat May 28 13:42:37 2016

  InstallationDate: Installed on 2016-05-24 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
  PackageArchitecture: all
  SourcePackage: linux-firmware
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: