← Back to team overview

kernel-packages team mailing list archive

[Bug 159356] Re: System freeze on high memory usage


I have the same problem.  Currently I'm using Ubuntu 14.04 64bits.  I
have 4GB of RAM and no swap.  If I open too many apps and memory usage
goes to 100%, the system completely freezes.

Before 14.04, I was using 8.04 32bits and this problem never happend. If
all the memory was used, new apps would just crash when trying to malloc
but the system will still remain solid stable.

My system is: Intel Core 2 Duo, 4GB RAM, nVidia GPU and Ubuntu 14.04.4

Tried already to increase /proc/sys/vm/min_free_kbytes to 270336, but
the problem persists.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  System freeze on high memory usage

Status in linux package in Ubuntu:

Bug description:
  I run a batch matlab job server here at my lab, running Dapper 6.06 (for the LTS). One of the users has submitted a very memory-consuming job, which successfully crashes the server. Upon closer inspection, the crash happens like this:
  1. I run matlab with the given file (as an ordinary, unpriveleged user)
  2. RAM usage quickly fills up
  3. Once the RAM meter hits 100%, the system freezes: All SSH connections freeze up, and while switching VTs directly on the machine works, no new processes run - so one can't log in, or do anything if he is logged in. (Sometimes typing doesn't work at all)

  Note that the swap - while 7 gigs of it are available - is never used.
  (The machine has 7 gigs of RAM as well)

  I've tried the same on my Gutsy 32-bit box, and there was no system
  freezeup - matlab simply notified that the system was out of memory.
  However, it did this once memory was 100% in use - and still, swap
  didn't get used at all! (Though it is mounted correctly and shows up
  in "top" and "free").

  So first thing's first - I'd like to eliminate the crash issue. I
  suppose I could switch the server to 32-bit, but I think that would be
  a performance loss, considering that it does a lot of heavy
  computation. There is no reason, however, that this should happen on a
  64-bit machine anyway. Why does it?

  WORKAROUND: Enabling DMA in the BIOS

To manage notifications about this bug go to: