← Back to team overview

kernel-packages team mailing list archive

[Bug 1587009] Re: hvc0 not present


When will this get fixed?

We want to use Ubuntu 16.04 Server in production on Xen, but it is not
usable this way.

I tried to boot paravirtualized with packages grub-xen and linux-image-
virtual installed, but it didn't boot at all.

Error in XenCenter:

The server failed to handle your request, due to an internal error.  The given message may give details useful for debugging the problem.
message: xenopsd internal error: VM = d7a5dbd8-6fff-b29c-8fbe-9f998c4a00a4; domid = 91; Bootloader.Bad_error Traceback (most recent call last):
  File "/usr/bin/pygrub", line 903, in ?
    fs = fsimage.open(file, part_offs[0], bootfsoptions)
IOError: [Errno 95] Operation not supported

Also tried with boot parameter console=hvc0.

Again without paravirtualization, booting works.

$ systemctl status dev-hvc0.device
● dev-hvc0.device
   Loaded: loaded
   Active: inactive (dead)

Maybe that helps. Can i do anything else to help debug this?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  hvc0 not present

Status in linux package in Ubuntu:

Bug description:
  i have installed Ubuntu 16.04 with debootstrap on a XenServer 6.2.

  i have also installed xe-guest-utilities, grub-xen and linux-image-

  when booting the VM, i don't see anything in the XenCenter console.

  i think this is because there is no hvc0 tty.

  as written here, it should start automatically:

  > lscpu
  Hypervisor vendor:     Microsoft
  Virtualization type:   full

  maybe Ubuntu don't recognize Xen?

  how can i get this working?


To manage notifications about this bug go to: