← Back to team overview

kernel-packages team mailing list archive

[Bug 1089856] Re: 8086:4238 [Lenovo ThinkPad T430 2347] Wireless network doesn't resume after suspend/resume (sometimes)


[Expired for linux (Ubuntu) because there has been no activity for 60

** Changed in: linux (Ubuntu)
       Status: Incomplete => Expired

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  8086:4238 [Lenovo ThinkPad T430 2347] Wireless network doesn't resume
  after suspend/resume (sometimes)

Status in “linux” package in Ubuntu:

Bug description:
  It seems that sometimes my wireless network interface disappears after

  When this happens, listing hardware with lshw does not show the
  wireless adapter.

  Reloading the wireless kernel module drivers does not work!
  The command I'm using to do that is the following:
  sudo rmmod iwlwifi mac80211 cfg80211 ; sudo modprobe cfg80211 ; sudo modprobe iwlwifi ; sudo modprobe mac80211

  And finally (and this is quite weird to me), a "soft restart" of the
  computer does not work! That is, selecting the "Restart" option from
  the logout menu doesn't work. The last time this happened I tried a
  "soft restart" 4 times and every time the wireless interface did not
  come up. However, as soon as I did a "hard reboot" (selecting Shutdown
  from the logout menu, waiting a few seconds and then starting the
  computer again) fixed the problem right away.

  This probably indicates that the wireless controller itself (hardware)
  is in some undefined state.

  I tried adding adding the following line to /etc/pm/config.d/config:

  That has not solved the problem.

  As I stated, I don't think this is happening every time I
  suspend/resume, but when it happens I consistently need a "hard
  reboot" to fix the problem and get my wireless interface up again. I
  will do a few suspend/resume cycles later to try to see how frequently
  this happens.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: linux-image-3.5.0-19-generic 3.5.0-19.30
  ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
  Uname: Linux 3.5.0-19-generic x86_64
  ApportVersion: 2.6.1-0ubuntu6
  Architecture: amd64
   /dev/snd/controlC0:  stefan     2112 F.... pulseaudio
   country IS:
   	(2402 - 2482 @ 40), (N/A, 20)
   	(5170 - 5250 @ 40), (N/A, 20)
   	(5250 - 5330 @ 40), (N/A, 20), DFS
   	(5490 - 5710 @ 40), (N/A, 27), DFS
  Date: Thu Dec 13 10:35:51 2012
  HibernationDevice: RESUME=UUID=339a99de-eef3-452e-b55c-a229bee214e5
  InstallationDate: Installed on 2012-09-20 (83 days ago)
  InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905)
  MachineType: LENOVO 2347W2U
  MarkForUpload: True
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-19-generic root=UUID=c8916e6c-a99f-43f1-9d8c-c1daf21fedac ro quiet splash vt.handoff=7
   linux-restricted-modules-3.5.0-19-generic N/A
   linux-backports-modules-3.5.0-19-generic  N/A
   linux-firmware                            1.95
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/25/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G1ET41WW (1.16 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2347W2U
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvrG1ET41WW(1.16):bd05/25/2012:svnLENOVO:pn2347W2U:pvrThinkPadT430:rvnLENOVO:rn2347W2U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2347W2U
  dmi.product.version: ThinkPad T430
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: