← Back to team overview

kernel-packages team mailing list archive

[Bug 734883] Re: mounting HFS+ volumes fails on large sector devices


With ubuntu 12.04 its still the same error. It works fine with ubuntu 9
and kernel 2.6.37 and below.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  mounting HFS+ volumes fails on large sector devices

Status in “linux” package in Ubuntu:
  Fix Released
Status in “util-linux” package in Ubuntu:
Status in “linux” source package in Oneiric:
  Fix Released
Status in “util-linux” source package in Oneiric:

Bug description:
  Binary package hint: util-linux

  Natty Alpha 3

  WIth Natty I only tried now to mount my iPod, but it doesn't work. It
  used to work great under Maverick, though.

  Here's what I get from dmesg:

  [  452.340069] hfs: unable to find HFS+ superblock
  [  452.410078] sd 7:0:0:0: [sdb] Bad block number requested
  [  452.410110] hfs: unable to find HFS+ superblock

  And this is the error message from the GUI dialog:

  Unable to mount 8.1 GB Filesystem

  Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sdb3,
         missing codepage or helper program, or other error
         In some cases useful info is found in syslog - try
         dmesg | tail  or so

    Installed: 2.17.2-9.1ubuntu2
    Candidate: 2.17.2-9.1ubuntu2
    Version table:
   *** 2.17.2-9.1ubuntu2 0
          500 http://us.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
          100 /var/lib/dpkg/status

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: mount 2.17.2-9.1ubuntu2
  ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
  Uname: Linux 2.6.38-6-generic x86_64
  NonfreeKernelModules: nvidia wl
  Architecture: amd64
  Date: Mon Mar 14 10:13:28 2011
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110210)
  SourcePackage: util-linux
  UpgradeStatus: Upgraded to natty on 2011-03-08 (5 days ago)

To manage notifications about this bug go to: