← Back to team overview

kernel-packages team mailing list archive

[Bug 366478] Re: 058f:6377 Alcor Micro Corp. Multimedia Card Reader don't work in Ubuntu 9.04/9.10


Hi, I think I solved the problem here, maybe this can help the others
who are experiencing it.

The hardware:
058f:6362 Alcor Micro Corp. Flash Card Reader/Writer

it used to work in the past but after a software upgrade it stopped

The problem:
the hardware was recognized (I could see the card reader in dmesg) but mass storage devices where not scanned automatically on insertion, and hence partitions where not found and mounted automatically.

The workaround:
Inserting a memory card showed nothing, but if I removed the usb_storage module and loaded it again leaving the memory card inserted, the device was scanned and the partition mounted.

The analysis:
So the hardware worked and the kernel driver worked too to some extent, just scanning at insertion time was broken.

A possible solution:
Enable polling like described in http://forums.funtoo.org/viewtopic.php?id=2243

$ echo 1000 > /sys/module/block/parameters/events_dfl_poll_msecs

After the command line above the memory card device were scanned and partition mounted automatically.
Note that the change will affect all block devices, not just the card reader, maybe not what you want.

Maybe there are better solutions, like adding some quirk to the kernel
driver to enable polling for this device only, or use udev rules to
enable polling only for this hardware when it is detected, leaving the
global setting at it's default value.

Regression analysis:
Maybe in the past polling was enabled, I don't know if in the kernel or by some userspace component, and in newer versions it was disabled making the device look nonfunctional.

   Antonio http://ao2.it

P.S. To those complaining about old bugs not being fixed, if possible
try providing the actual problematic hardware to developers, that
generally gives them motivation to fix the problems.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  058f:6377 Alcor Micro Corp. Multimedia Card Reader don't work in
  Ubuntu 9.04/9.10

Status in “linux” package in Ubuntu:

Bug description:
  In Ubuntu 8.10 this cardreader - work fine, but after upgrade Ubuntu
  from 8.10 to 9.04 - it's not work.

  In lsusb - it displayed:
  Bus 001 Device 005: ID 058f:6377 Alcor Micro Corp. Multimedia Card Reader
  but in system - not displayed.
  When insert memory card - nothing happened (only green diod light)

  Ubuntu 9.04 amd64
  uname -a:
  Linux leolik-komp 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

To manage notifications about this bug go to: