← Back to team overview

kernel-packages team mailing list archive

[Bug 1014749] Re: can't read uvcvideo (usb video / webcams) devices


[Expired for linux (Ubuntu) because there has been no activity for 60

** Changed in: linux (Ubuntu)
       Status: Incomplete => Expired

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  can't read uvcvideo (usb video / webcams) devices

Status in “linux” package in Ubuntu:

Bug description:
  Attempting to read /dev/video0 for USB video device gives:

  libv4l2: error turning on stream: No space left on device

  from the video4linux library, and the video4linux ioctl fail with e.g.

  VIDIOC_STREAMON - Unable to start capture: Device or resource busy

  I wrote a test program and find that "Control" ioctls such as
  VIDIOC_G_FMT are successful: I can query the format which the camera
  provides, so the "connection" with the camera seems OK.

  Reading the frame, however seems impossible.

  (cheese and guvcview are also unable to display an image, so it isn't
  just my programming - and my program does work on a laptop which runs
  NetBSD, so no ubuntu testing there)

  I tested the following cameras
  Bus 002 Device 003: ID 046d:09a1 Logitech, Inc. QuickCam Communicate MP/S5500
  Bus 002 Device 004: ID 0471:2038 Philips (or NXP) 
  Bus 002 Device 006: ID 041e:406d Creative Technology, Ltd 

  (I also tried with ubuntu 10.04)

  Most similar bugs have been "solved" in the past by installing new kernels - the above was tried with the most recent at the time of this report:
   3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

  This computer has USB3 ports as well as USB2 ports - I have tried a
  variety - apport should show the Logitech plugged into a USB2 port.

  These cameras work on other compurters running 10.04 - if I had to
  guess, this is the only computer I have with USB3 ports - so is it a
  USB controller driver issue?

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-25-generic 3.2.0-25.40
  ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
  Uname: Linux 3.2.0-25-generic x86_64
  NonfreeKernelModules: fglrx
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC2:  prlw1      2485 F.... pulseaudio
   /dev/snd/controlC0:  prlw1      2485 F.... pulseaudio
   /dev/snd/controlC1:  prlw1      2485 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'PCH'/'HDA Intel PCH at 0xe0520000 irq 95'
     Mixer name	: 'Realtek ALC892'
     Components	: 'HDA:10ec0892,80862018,00100302'
     Controls      : 41
     Simple ctrls  : 20
   Card hw:1 'U0x46d0x9a1'/'USB Device 0x46d:0x9a1 at usb-0000:00:1d.0-1.8, full speed'
     Mixer name	: 'USB Mixer'
     Components	: 'USB046d:09a1'
     Controls      : 2
     Simple ctrls  : 1
   Simple mixer control 'Mic',0
     Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
     Capture channels: Mono
     Limits: Capture 0 - 3072
     Mono: Capture 1536 [50%] [24.00dB] [on]
   Card hw:2 'Generic'/'HD-Audio Generic at 0xe0320000 irq 96'
     Mixer name	: 'ATI R6xx HDMI'
     Components	: 'HDA:1002aa01,00aa0100,00100200'
     Controls      : 6
     Simple ctrls  : 1
   Simple mixer control 'IEC958',0
     Capabilities: pswitch pswitch-joined penum
     Playback channels: Mono
     Mono: Playback [on]
  CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
  Date: Mon Jun 18 17:50:12 2012
  IwConfig: Error: [Errno 2] No such file or directory
   PATH=(custom, no user)
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-25-generic root=UUID=69f474df-7e0b-4e6e-a210-904b21597280 ro quiet splash vt.handoff=7
  RfKill: Error: [Errno 2] No such file or directory
  SourcePackage: linux
  UdevDb: Error: [Errno 2] No such file or directory
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/27/2012
  dmi.bios.vendor: Intel Corp.
  dmi.bios.version: SIX7910J.86A.0460.2012.0327.1627
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: DX79SI
  dmi.board.vendor: Intel Corporation
  dmi.board.version: AAG28808-600
  dmi.chassis.type: 3
  dmi.modalias: dmi:bvnIntelCorp.:bvrSIX7910J.86A.0460.2012.0327.1627:bd03/27/2012:svn:pn:pvr:rvnIntelCorporation:rnDX79SI:rvrAAG28808-600:cvn:ct3:cvr:

To manage notifications about this bug go to: