← Back to team overview

kernel-packages team mailing list archive

[Bug 962712] [NEW] Battery charging slows down my thinkpad severely


You have been subscribed to a public bug:

I have a ThinkPad L520 (7859-5BG) Core i5-2520M(2.5GHz) with 4GB RAM and
Ubuntu 11.10 32-bit install and with gnome classic (no effects)

When my battery is charging via power adapter, system is severely slow. This is most often visible when just about every process takes very high CPU (e.g. gnome-panel consuming 60% or chrome consuming 118% of CPU). Working with the laptop is almost impossible due to very slow processing. Clicking "applications" in panel takes 1 second to appear.

During the above state - as soon as I disconnect my power adapter, CPU
usage drops to less than 10%, and system becomes super smooth and quick
again. Also, when the battery gets completely charged, laptop (kindof)
stops lagging much.  Also, I took my battery out of my laptop, and
powered it directly via AC adapter, and system was super smooth.

My laptop is dual-boot (despite my hatred for Windows), and I have
tested battery charging on Windows. THere is NO LAG AT ALL !   This
confirms that there is no hardware fault, as windows is quick and fast
during battery charging.

The state of the system is confirmed - means I can recreate the problem
almost every time. I have tried "top" to see processes and how they
look, but no "strange" process is there for one to be able to kill. Its
essentially the same processes that start hogging my CPU completely
(chrome, nautilus, gnome-panel, just-any-running-process.... )

I have also tried another brand new charger from Lenovo - but same
problem there.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7.1
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic-pae 3.0.20
Uname: Linux 3.0.0-16-generic-pae i686

ApportVersion: 1.23-0ubuntu4
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgpng,move,snap,grid,gnomecompat,resize,regex,animation,vpswitch,mousepoll,unitymtgrabhandles,place,wall,session,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: None
Date: Fri Mar 23 02:09:39 2012
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21dd]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 78595BG
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic-pae root=UUID=dec2de3b-50bd-4850-b890-b645f6457392 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET38WW (1.15 )
dmi.board.name: 78595BG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET38WW(1.15):bd11/04/2011:svnLENOVO:pn78595BG:pvrThinkPadL520:rvnLENOVO:rn78595BG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 78595BG
dmi.product.version: ThinkPad L520
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6.1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

** Affects: linux (Ubuntu)
     Importance: Medium
         Status: Incomplete

** Tags: apport-bug bios-outdated-1.23 i386 needs-upstream-testing oneiric performance precise regression-potential ubuntu
Battery charging slows down my thinkpad severely
You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.