← Back to team overview

kernel-packages team mailing list archive

[Bug 1228109] Re: [Lenovo ThinkCentre M91p] System freezes


Daniel Arnitz, the crash file you posted appears to be a crash file from your /var/crash folder, not a kernel call trace or xorg backtrace. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. First, execute at a terminal:
cd /var/crash && sudo rm * ; sudo apt-get update && sudo apt-get -y upgrade && sudo service apport start force_start=1

If you are running the Ubuntu Stable Release you might need to enable
apport in /etc/default/apport and restart.

Now reproduce the crash, then open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'. If you run the command against the crash report and it does nothing, you may be affected by https://bugs.launchpad.net/ubuntu/+source/apport/+bug/994921 . In order to WORKAROUND this, one would need to open the following file via a command line:
gksudo gedit /etc/apport/crashdb.conf

and comment out the line:
'problem_types': ['Bug', 'Package'],

by changing it to:
# 'problem_types': ['Bug', 'Package'],

Save, close, and try to file the crash report again via:
ubuntu-bug /var/crash/_my_crash_report.crash

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Lenovo ThinkCentre M91p] System freezes

Status in “linux” package in Ubuntu:

Bug description:
  * Problem description: The system freezes completely. This includes
  screen, mouse, and keyboard including numlock light. Even after
  several weeks of testing I was not able to tie the freezes to a
  specific event, program, or behavior. There seem to be a few scenarios
  where freezes are more likely (see below), but they can essentially
  occur at any time. I have updated my bios and the system; this did not
  solve the problem. I have not yet tried the mainline kernel, since I
  am unsure which version to select.

  * Steps to reproduce: Run long-term measurement device remote control in Matlab (data collection; SCPI, low cpu load, some network, a couple GB RAM usage). The system typically freezes within 24 to 48 hours. I have also tried several other scenarios:
  - normal work with KDE (Kile, Thunderbird, Firefox, Inkscape, VLC, Dolphin): RARELY (~ once a month)
  - measurement device remote control in Matlab (memory, network).

  The following didn't seem to reproduce the problem:
  - running date + sleep in a bash loop.
  - running date + sleep in a bash loop within screen.
  - running ping constantly.
  - idle loop in Matlab (do nothing).
  - random data copying loop in Matlab (memory only).

  * Keeping CPU load high by inverting a some matrix in the data
  collection loop seems to prevent this problem.

  * Last working version: Kubuntu 11.10

  * Additional information:
  - memory test came back negative (no problems)
  - crash is reproducible on a text console
  - could not obtain trace dump (system does not react to keyboard)

  Neither of the following fixed the problem:
  xserver-xorg-lts-quantal libgl1-mesa-dri-lts-quantal:i386 libgl1-mesa-glx-lts-quantal:i386

  or fixing the "*BAD*gran_size" issue described in:

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.5.0-40-generic 3.5.0-40.62~precise1
  ProcVersionSignature: Ubuntu 3.5.0-40.62~precise1-generic
  Uname: Linux 3.5.0-40-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
  ApportVersion: 2.0.1-0ubuntu17.4
  Architecture: amd64
   /dev/snd/controlC1:  arnitz     2208 F.... pulseaudio
   /dev/snd/controlC0:  arnitz     2208 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
   Card hw:0 'PCH'/'HDA Intel PCH at 0xfe520000 irq 44'
     Mixer name	: 'Intel CougarPoint HDMI'
     Components	: 'HDA:10ec0662,17aa3070,00100101 HDA:80862805,17aa3070,00100000'
     Controls      : 36
     Simple ctrls  : 16
   Card hw:1 'Audio'/'Plantronics Wireless Audio Plantronics Wireless Audio at usb-0000:00:1d.0-1.4, '
     Mixer name	: 'USB Mixer'
     Components	: 'USB047f:d955'
     Controls      : 4
     Simple ctrls  : 2
  Date: Fri Sep 20 08:13:34 2013
  HibernationDevice: RESUME=UUID=2f562564-0248-4280-a46b-9cd0f0e8e5e6
  InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
   eth0      no wireless extensions.

   eth1      no wireless extensions.

   lo        no wireless extensions.
  MachineType: LENOVO 4524-AN4
  MarkForUpload: True
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-40-generic root=UUID=af77f384-9007-4d2b-8395-5ada0dcfb93e ro quiet splash enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=64K mtrr_chunk_size=256M vt.handoff=7
   linux-restricted-modules-3.5.0-40-generic N/A
   linux-backports-modules-3.5.0-40-generic  N/A
   linux-firmware                            1.79.6

  SourcePackage: linux
  UpgradeStatus: Upgraded to precise on 2013-06-20 (91 days ago)
  dmi.bios.date: 10/16/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 9HKT54AUS
  dmi.board.vendor: LENOVO
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnLENOVO:bvr9HKT54AUS:bd10/16/2012:svnLENOVO:pn4524-AN4:pvrThinkCentreM91p:rvnLENOVO:rn:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: 4524-AN4
  dmi.product.version: ThinkCentre M91p
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: