← Back to team overview

kernel-packages team mailing list archive

[Bug 991902] Re: blinking blank screen after booting [asus zenbook ux21]


Ivan Zorin, as per
https://www.asus.com/Notebooks_Ultrabooks/ASUS_ZENBOOK_UX21E/#support an
update is available for your BIOS (214). If you update to this following
https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so
posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see

Thank you for your understanding.

** No longer affects: xserver-xorg-video-intel (Ubuntu)

** Tags removed: asus black-screen flicker gma intel lts needs-reassignment screen
** Tags added: bios-outdated-214 needs-upstream-testing

** Changed in: linux (Ubuntu)
       Status: Triaged => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  blinking blank screen after booting [asus zenbook ux21]

Status in “linux” package in Ubuntu:
Status in “linux” package in Fedora:

Bug description:
  Hardware: Asus Zenbook UX21e
  Software: Ubuntu 12.04 LTS

  This issue have begun from booting LiveCD - I've dowloaded iso, burned
  it and loaded using external CD drive: screen was blinking couple
  times during boot. However, after booting system seems stable, so
  during installation wasn't any problems at all.

  After first boot into installed system I've noticed the following behavior:
   - display is blinking couple times during boot
   - display is blinking couple times on lightdm login screen
   - after login display also is blinking couple times, buf after this system looks like usable and stable

  The symptoms above is repeating each time on boot now, but *SOMETIMES* display becomes totaly blank after blinking - it may be blank:
   - during boot
   - after boot, but before lightdm screen shows up (I can hear logon screen sound when display is blank already)
   - after login - I've entered login/password, desktop shows up, display is blanking, and then display is never showing up again
   - if i run 'xrandr' from terminal, then screen is blinking (probably, when tries to detect supported resolutions) one time just as during boot

  Some additional information:
   - all currrent updates is installed
   - screen is not black/turned off - it's *blank* (i can see LED light for screen)
   - I've tried another kernels from Kernel Mainline PPA (http://kernel.ubuntu.com/~kernel-ppa/mainline/ : I've tested 'daily', 'drm-intel-fixes' and 'drm-intel-next' - no any success at all; behavior is the same)
   - I've tried another xorg-related packages from XOrg Edgers PPA - behavior is still the same
   - I can't see TTYs, if screen goes blank during/after boot - I can switch to TTY 'in blind': ctrl+alt+f2, and it works, for example: type login/password, run 'sudo reboot', type password; but on TTY screen is also blank
   - switching to TTY's after booting and login in with 'working' screen may cause screen to blank it

  Non-working workarounds (https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen#How_It_Works):
   - I've tried to remove 'quite splash' from 'linux' line in grub config (by editing /etc/default/grub and doing sudo update-grub)
   - I've tried to add 'set gfxpayload=text' option in menu entry on boot using grub

  Working workaround:
   - add 'nomodeset' to 'linux' line in grub config: after this no any issues described above, system is booting stable, but, obviously, user has lost additional graphics hardware acceleration and features (unity-3d/compiz/compositing/etc), and that's very sad.

  Similar bugs - although I can't google exactly the same issue, but looks like that the following bug may be related to my issue:
   - https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/681054?comments=all

  I will be very appreciate for any confirmations; also I would like to help by testing/providing necessary logs for fix this issue as soon as possible.
  ApportVersion: 2.0.1-0ubuntu7
  Architecture: amd64
  CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
  CompositorRunning: None
  DistUpgraded: Fresh install
  DistroCodename: precise
  DistroRelease: Ubuntu 12.04
  DistroVariant: ubuntu
  ExtraDebuggingInterest: No
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:1417]
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
  MachineType: ASUSTeK Computer Inc. UX21E
  Package: xserver-xorg-video-intel 2:2.18.0+git20120416.a1661620-0ubuntu0sarvatt [origin: LP-PPA-xorg-edgers]
  PackageArchitecture: amd64
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.4.0-999-generic root=UUID=fe676054-057c-445a-bffa-c42edb651348 ro nomodeset
  Tags: precise third-party-packages ubuntu regression-update needs-reassignment
  Uname: Linux 3.4.0-999-generic x86_64
  UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm lpadmin sambashare sudo users
  dmi.bios.date: 09/30/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: UX21E.205
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: UX21E
  dmi.board.vendor: ASUSTeK Computer Inc.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK Computer Inc.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX21E.205:bd09/30/2011:svnASUSTeKComputerInc.:pnUX21E:pvr1.0:rvnASUSTeKComputerInc.:rnUX21E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
  dmi.product.name: UX21E
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK Computer Inc.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.33+git20120403.43704256-0ubuntu0ricotz
  version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2+git20120429+8.0.e995b41a-0ubuntu0sarvatt
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2+git20120429+8.0.e995b41a-0ubuntu0sarvatt
  version.xserver-xorg-core: xserver-xorg-core 2:1.12.1+git20120428+server-1.12-branch.9ef48c9f-0ubuntu0ricotz~precise
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0+git20120328.99340147-0ubuntu0sarvatt
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99+git20120412.d282719a-0ubuntu0sarvatt
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.18.0+git20120416.a1661620-0ubuntu0sarvatt
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20120328.ab7291d3-0ubuntu0sarvatt

To manage notifications about this bug go to: