← Back to team overview

kernel-packages team mailing list archive

[Bug 1032342] Re: 090c:1000 file transfer to/from USB 2.0 flash drive, via 3.0 port at best 50-60 Mb/s


truant, as per
http://www.toshiba.co.uk/innovation/download_bios.jsp?service=UK an
update is available for your BIOS (6.30). If you update to this
following https://help.ubuntu.com/community/BiosUpdate , does it change

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so
posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see

Thank you for your understanding.

** Tags added: bios-outdated-6.30

** Changed in: linux (Ubuntu)
       Status: Triaged => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  090c:1000 file transfer to/from USB 2.0 flash drive, via 3.0 port at
  best 50-60 Mb/s

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  USB transfers to/from flash drives are very slow. Disk Utility reports
  the various drives I've tried are connected at 480Mb/s, but it's rare
  to see transfers faster than 50-60Mb/s at best, probably less as
  nautilus only reports average speed which is skewed by the first 300Mb
  being buffered.

  Sometimes I get the first 300MB very fast followed by very slow and
  ending with a long pause while the write buffer writes out, sometimes
  they're just very slow from the start. Doesn't seem to matter if I'm
  transferring one big file or lots of little files.  Seems faster with
  USB HDs.  Flash drives I've tried so far are all working fine in other
  OSes on the same machine.

  Also occurring with bleeding edge kernel (which I'm using because
  anything younger won't suspend properly on my machine),
  3.5.0-999-generic #201207280406 SMP Sat Jul 28 08:07:29 UTC 2012
  x86_64 x86_64 x86_64 GNU/Linux.

  The reason I'm reporting it here rather than at kernel.org is that I
  don't think it's a kernel bug, I think it's to do with Debian/Ubuntu's
  kernel patches.  Because it doesn't happen in the live version of
  Fedora 17 I tried, but it does happen with Debian Wheezy.  Windows 7
  is also fast.

  Laptop is a Toshiba L830-114.   Attached is a usbmon log of dd
  if=/dev/zero of=/media/littlun/tmp oflag=direct bs=120K count=2K as
  recommended by Ming Lei here:

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-27-generic 3.2.0-27.43
  ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
  Uname: Linux 3.2.0-27-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu11
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  mat        1731 F.... pulseaudio
   Card hw:0 'PCH'/'HDA Intel PCH at 0xc0600000 irq 43'
     Mixer name	: 'Intel PantherPoint HDMI'
     Components	: 'HDA:14f1506e,1179fb90,00100003 HDA:80862806,1179fb90,00100000'
     Controls      : 25
     Simple ctrls  : 12
  CurrentDmesg: [   30.118970] wlan1: no IPv6 routers present
  Date: Thu Aug  2 20:18:24 2012
  HibernationDevice: RESUME=UUID=99547817-de1c-4c35-9bb3-845962582ed6
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic root=UUID=1c27fdd8-65a9-4b9c-8e8b-ba5e4660a55b ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-27-generic N/A
   linux-backports-modules-3.2.0-27-generic  N/A
   linux-firmware                            1.79
  SourcePackage: linux
  StagingDrivers: mei
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/11/2012
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: 1.50
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: Type2 - Board Product Name1
  dmi.board.vendor: Type2 - Board Vendor Name1
  dmi.board.version: Type2 - Board Version
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: OEM Chassis Manufacturer
  dmi.chassis.version: OEM Chassis Version
  dmi.modalias: dmi:bvnInsydeCorp.:bvr1.50:bd06/11/2012:svnTOSHIBA:pnSATELLITEL830:pvrPSK7YE-00J004EN:rvnType2-BoardVendorName1:rnType2-BoardProductName1:rvrType2-BoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
  dmi.product.name: SATELLITE L830
  dmi.product.version: PSK7YE-00J004EN
  dmi.sys.vendor: TOSHIBA

To manage notifications about this bug go to: