← Back to team overview

kernel-packages team mailing list archive

[Bug 1088395] Re: 18ec:3299 Can't read uvcvideo (usb video / webcam) device


Kzhi, this bug was reported a while ago and there hasn't been any
activity in it recently. We were wondering if this is still an issue? If
so, could you please test for this with the latest development release
of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
/daily-live/current/ .

If it remains an issue, could you please run just make a comment to

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** Summary changed:

- Can't read uvcvideo (usb video / webcams) devices
+ 18ec:3299 Can't read uvcvideo (usb video / webcam) device

** Tags added: latest-bios-1202 needs-upstream-testing regression-

** Attachment removed: "lsb_release.txt"

** Attachment removed: "lspci.txt"

** Attachment removed: "proc.cpu.txt"

** Attachment removed: "proc.modules.txt"

** Attachment removed: "ver_linux.txt"

** Changed in: linux (Ubuntu)
       Status: Triaged => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  18ec:3299 Can't read uvcvideo (usb video / webcam) device

Status in “linux” package in Ubuntu:

Bug description:
  Attempting to read /dev/video0 for USB video device gives:
  libv4l2: error turning on stream: No space left on device

  I tested the camera:
  Bus 002 Device 006: ID 18ec:3299 Arkmicro Technologies Inc. 

  The hardware on that machine, is ok. I also have win7 installed and
  the camera works in it.

  I tested this camera on other two machines with Ubuntu 12.10 and it
  works out of the box (luvcview, guvcview).

  I was unable to boot with latest mainline kernels (3.7rc8 or 3.6.9) to
  test whether the error remains. Although in ArchBang live cd (3.6.9
  kernel) the same error still was there when I tried to capture.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: linux-image-3.5.0-17-generic 3.5.0-17.28
  ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
  Uname: Linux 3.5.0-17-generic x86_64
  ApportVersion: 2.6.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  egor       1622 F.... lxpanel
  CRDA: Error: [Errno 2] No such file or directory: 'iw'
  Date: Mon Dec 10 12:36:30 2012
  InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
   ppp0      no wireless extensions.
   eth0      no wireless extensions.
   lo        no wireless extensions.
  MachineType: System manufacturer System Product Name
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=6d9d5763-f6e4-4eee-b11a-80964cb90b93 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.5.0-17-generic N/A
   linux-backports-modules-3.5.0-17-generic  N/A
   linux-firmware                            1.95
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/11/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1202
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P7Q57-M DO
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev x.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1202:bd05/11/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7Q57-MDO:rvrRevx.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: