← Back to team overview

kernel-packages team mailing list archive

[Bug 1090715] Re: [Toshiba L840] Slow and sporadic hard drive write performance


Hello Christopher-

This laptop was ordered custom from Toshiba Direct so I beleive
Satellite L840 is the entire model number. I am looking at the sticker
right now and this is all I see...

btw, Ubuntu 13.04 and 13.10 64-bit work flawlessly on this laptop. I was
never able to get the pae kernel to function properly...

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Toshiba L840] Slow and sporadic hard drive write performance

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  I have been troubleshooting an interesting bug on my Toshiba L840
  laptop for a number of months now. This bug affects all versions of
  Ubuntu since (and including) 12.04 and other Linux distributions as
  well (so this is most likely an upstream bug). I have only ran the
  32-bit version with PAE support because I choose application
  compatibility and efficient memory usage over what 64-bit Linux can

  WORKAROUND: 64-bit ubuntu raring (13.04).

  Here is what I have experienced:

  Every kernel version I have tried is affected by this bug since 3.2 in
  Precise (kernel 3.3 - 3.7 is affected). What happens is my hard drive
  write performance is greatly reduced (and over time it becomes so slow
  it is unusable) once I run a newer version of Linux kernel. The stock
  kernel of Precise does not have this bug but it has too many other
  bugs that cause hard lockups on ivy bridge so I cannot use it. I am
  happy to report that the hard lockups seem to have disappeared on
  13.04 (Linux kernel 3.7) and the most stable experience I have had so
  far is with kernel version 3.7.0-5 on Raring 32-bit.

  Even though I have found a relatively stable experience running Raring
  I am still haunted by this write performance issue. Once I boot I can
  get consistent write speeds at about 40MB/s (which is about half the
  speed of what my drive is able to write at) and read speed never
  really seems to be affected. Here is a test using dd to check write

  owner@Satellite-L840:~$ dd if=/dev/zero of=/tmp/output bs=8k count=50k; rm -f /tmp/output
  51200+0 records in
  51200+0 records out
  419430400 bytes (419 MB) copied, 10.6863 s, 39.2 MB/s
  owner@Satellite-L840:~$ dd if=/dev/zero of=/tmp/output bs=8k count=50k; rm -f /tmp/output
  51200+0 records in
  51200+0 records out
  419430400 bytes (419 MB) copied, 10.4765 s, 40.0 MB/s
  owner@Satellite-L840:~$ dd if=/dev/zero of=/tmp/output bs=8k count=50k; rm -f /tmp/output
  51200+0 records in
  51200+0 records out
  419430400 bytes (419 MB) copied, 10.4648 s, 40.1 MB/s
  owner@Satellite-L840:~$ dd if=/dev/zero of=/tmp/output bs=8k count=50k; rm -f /tmp/output
  51200+0 records in
  51200+0 records out
  419430400 bytes (419 MB) copied, 11.2678 s, 37.2 MB/s

  Even though 40MB/s write speed is completely unacceptable I would
  actually be okay with it if it didn't drop any lower than this but
  eventually it does.

  I have experienced that over time eventually the write speed of the
  drive will drop to about 1-2MB/s and at that point the computer
  becomes unusable and has to be rebooted.

  Strangely enough I have finally noticed that the significant drop from
  40MB/s to 1-2MB/s seems to be triggered by certain applications, for
  instance when I have a torrent downloading using various torrent
  downloader programs, I have experienced this bug more frequently.

  Even so, if I choose to not use the torrent downloading programs the
  bug will eventually crop back up (could be hours, could be several
  days...) but eventually it happens and I have to reboot.

  Here are some more troubleshooting steps I have tried in a failed attempt to isolate the issue:
  * I have ran memtest 86+ for over 24 hours on my laptop and it completed without error
  * I have scanned my hard drive using mhdd and no bad sectors
  * I have replaced my hard drive with a different size and different brand hard drive and same issue
  * I have attempted a clean install of Precise and then updating to the latest packages and then install the Quantal kernel from the stable repositories and reboot. Immediately this bug affects my computer
  * I have installed a clean install of 13.04 and bug still exists
  * I have tried installing Ubuntu (12.04 and 13.04 32-bit) on a flash drive to see if the bug crops up eventually on the flash drive and it does. Eventually the write speed even to the USB bus will drop to 1-2MB/s !!!
  * I have even tried installing other distributions as well (Fedora and Debian) and they both have the same issue.

  One more thing worth noting: The very first kernel release that I
  tried in 13.04 was 3.7.0-2 and even now if I reboot and choose that
  kernel I get better write performance at first (70-80MB/s) but
  eventually the write speed drops down to 1-2 MB/s just like the

  I have experienced many problems running Linux on this laptop but even
  so it is the fastest and best performing computer experience I have
  ever had. Now that the lockups are gone I feel so close to getting
  this computer working perfectly with Linux but I need help from
  someone with troubleshooting this issue further.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: linux-image
  ProcVersionSignature: Ubuntu 3.7.0-5.13-generic 3.7.0-rc8
  Uname: Linux 3.7.0-5-generic i686
  ApportVersion: 2.7-0ubuntu2
  Architecture: i386
   /dev/snd/controlC0:  acjohnson   2197 F.... pulseaudio
  Date: Sat Dec 15 07:13:04 2012
  HibernationDevice: RESUME=UUID=9f7c92ad-121c-458f-8813-1cb8191180c2
  InstallationDate: Installed on 2012-12-10 (5 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121206)
  MachineType: TOSHIBA Satellite L840
  MarkForUpload: True
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.7.0-5-generic root=UUID=4836d385-16fc-47c0-8720-c369e39d0775 ro quiet splash i915.i915_enable_rc6=7 vt.handoff=7
   linux-restricted-modules-3.7.0-5-generic N/A
   linux-backports-modules-3.7.0-5-generic  N/A
   linux-firmware                           1.98
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/26/2012
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: 1.80
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: Type2 - Board Product Name1
  dmi.board.vendor: Type2 - Board Vendor Name1
  dmi.board.version: Type2 - Board Version
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: OEM Chassis Manufacturer
  dmi.chassis.version: OEM Chassis Version
  dmi.modalias: dmi:bvnInsydeCorp.:bvr1.80:bd06/26/2012:svnTOSHIBA:pnSatelliteL840:pvrPSK8GU-08S00D:rvnType2-BoardVendorName1:rnType2-BoardProductName1:rvrType2-BoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
  dmi.product.name: Satellite L840
  dmi.product.version: PSK8GU-08S00D
  dmi.sys.vendor: TOSHIBA

To manage notifications about this bug go to: