← Back to team overview

kernel-packages team mailing list archive

[Bug 906873] Re: mpt2sas driver is unusable


This problem still persists in Saucy using latest LSI firmware (, bios,
although it's not as bad as it used to be - it doesn't crash within hours anymore but rather weeks
(although a few times twice within a few hours). But when it crashes it crashes hard - all disks
on the controller freeze (I can only see syslog entries before the crash by directing syslog to
another machine).

So, it's still too bad to allow using smartd or hddtemp in mission-
critical machines.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  mpt2sas driver is unusable

Status in “linux” package in Ubuntu:

Bug description:
  I have a Supermicro computer with integrated LSI raid controller.

  I tried many version of kernel and driver with no success.

  All of them give me at least this error message:

  [  272.434551] scsi target6:1:0: volume handle(0x0143), volume wwid(0x095379ae0ead6e88)
  [  272.434557] sd 6:1:0:0: task abort: FAILED scmd(ffff88100da5ce00)
  [  272.434561] sd 6:1:0:0: attempting task abort! scmd(ffff88100da5d800)
  [  272.434565] sd 6:1:0:0: [sda] CDB: Write(10): 2a 00 00 a5 31 04 00 04 00 00

  The newest version (11.00) makes a kernel panic and oops. Unfortunately I have no null modem cable, to grab the oops message through serial console.

  I tried with the following scenarios (all amd64):

  Ubuntu 10.04 2.6.32: this error message
  Ubuntu 12.04 (Precise) beta: 3.2.0: this error message
  Ubuntu 10.04 backported kernel 2.6.38: this error message
  Ubuntu 10.04 backported kernel 2.6.38 + driver from ftp://ftp.supermicro.com/driver/SAS/LSI/2008/IR/Driver/Linux/PH10-00.00/ : kernel panic at bootime
  Ubuntu 10.04 backported kernel 2.6.38 + driver from ftp://ftp.supermicro.com/driver/SAS/LSI/2008/IR/Driver/Linux/PH11-00.00/: kernel panic at boottime
  Scientific Linux 6.1: kernel panic at install boot time (some weird apic function, probably not related)
  Scientific Linux 6.1 with noapic kernel parameter: just hang up
  Scientific Linux 5.7: this error message at install time, no hangup, but mkfs was not success after an hour

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-6-generic 3.2.0-6.12
  ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
  Uname: Linux 3.2.0-6-generic x86_64
   total 0
   crw-rw---T 1 root audio 116,  1 Dec 20 13:18 seq
   crw-rw---T 1 root audio 116, 33 Dec 20 13:18 timer
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 1.90-0ubuntu1
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  Date: Tue Dec 20 14:03:33 2011
  HibernationDevice: RESUME=/dev/mapper/vg0-swap
  IwConfig: Error: [Errno 2] No such file or directory
  MachineType: Supermicro H8QG6
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-6-generic root=/dev/mapper/vg0-root ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-6-generic N/A
   linux-backports-modules-3.2.0-6-generic  N/A
   linux-firmware                           1.66
  RfKill: Error: [Errno 2] No such file or directory
  SourcePackage: linux
  UpgradeStatus: Upgraded to precise on 2011-12-20 (0 days ago)
  dmi.bios.date: 09/26/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2.00
  dmi.board.asset.tag: 1234567890
  dmi.board.name: H8QG6
  dmi.board.vendor: Supermicro
  dmi.board.version: 1234567890
  dmi.chassis.asset.tag: 1234567890
  dmi.chassis.type: 17
  dmi.chassis.vendor: Supermicro
  dmi.chassis.version: 1234567890
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2.00:bd09/26/2011:svnSupermicro:pnH8QG6:pvr1234567890:rvnSupermicro:rnH8QG6:rvr1234567890:cvnSupermicro:ct17:cvr1234567890:
  dmi.product.name: H8QG6
  dmi.product.version: 1234567890
  dmi.sys.vendor: Supermicro

To manage notifications about this bug go to: