← Back to team overview

kernel-packages team mailing list archive

[Bug 1107150] Re: B75 Chipset I/O Problems


Great to finally see this bug being worked on... I found a bunch of
similar bug reports that were finally closed (and supposedly solved)
because the original bug reporter ended up installing a 64-bit kernel

Here's what I found out so far:
* This bug only affects writing to block devices. Read speeds are absolutely fine. It would be nice if the other people could confirm this!
* This bug isn't related to the B75 chipset. I'm also experiencing this bug on a somewhat older chipset. I believe I'm using an Intel Q57 Express chipset but I doubt whether this is really relevant.
* It will only trigger with the x86 kernel, not the amd64 kernel.
* This bug _probably_ isn't limited to Ubuntu, Ubuntu is just the only distro that triggers it. I tested the following distributions:

  + Fedora 19 (32 bit) live cd (3.9.x kernel) -> works fine
  + OpenSuSe 13.1 (32 bit) live cd (3.11 kernel) -> works fine
  + Ubuntu 13.10 (32 bit) live cd (3.11 kernel) -> doesn't work
  + Ubuntu 13.10 (64 bit) live cd (3.11 kernel) -> works fine
  + Linux Mint 16 (32 bit) live cd (3.11 kernel) -> doesn't work
  + Debian 7.2 (32 bit) live cd (3.2 kernel) -> works fine

I then went back to Ubuntu 12.10 32 bit (3.5.5 kernel) and confirmed

  + Running with only 8 Gigs of RAM gives me write speeds of 180-200Mb/sec
  + Running with 16 Gigs of RAM gives me write speeds of 160-180Mb/sec
  + Running with 32 Gigs of RAM gives me write speeds of 1.5-5.5Mb/sec

I downloaded a stock 3.5.5 kernel tarball and compiled it with the
ubuntu kernel config. The problem persists.

There is a similar bug where pc's suddenly get terrible write speeds to
block devices after waking up from suspend. This bug is caused by the
fact that on some pc's MTRR registers change after waking up. After
comparing Ubuntu, Fedora and Suse kernel configs, I noticed that Ubuntu
is the only distro using the MTRR sanitizer. I disabled it but the
problem persists.

This definitely seems like an mm problem to me. I'd like to test the
latest test kernel you've built but it's only available for amd64 (which
never had the problem anyway).

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  B75 Chipset I/O Problems

Status in “linux” package in Ubuntu:

Bug description:
  I built a new system and installed Ubuntu 12.10. The system has the
  following specifications:

  Samsung 840 Pro 128 GB 
  Gigabyte P75-D3
  Intel i7 3770
  32 GB Ram
  Western Digital 1 TB Black (mounted as /home)
  Western Digital 3 TB Green (mounted as /media/data_drive)

  The initial Ubuntu 12.10 install took almost 6 hours as transfer rates
  were very slow. After reboot everything appeared very fast. However
  when I did an "apt-get update" the download took 20 seconds and the
  processing of lists took 19 minutes.

  I had 12.10 installed on another computer which was working great
  (older Althon system) so I installed the drive and tested the new
  machine. It suffered the same performance problems.

  I installed Windows 7 and performed speeds tests, it reported great

  I installed 12.04 onto the 1 TB drive and it did not suffer the same
  performance problems. Everything ran great.

  I then upgraded 12.10 to 13.04 (January 27, 2013) and it too suffered
  from the performance issue.

  It appears that a change between 12.04 to 12.10 impacts AHCI based
  systems specifically running the Intel B75 chipset. I am not certain
  but I think that either the motherboard is misrepresenting something
  (that 12.04 ignores but it impacts 12.10) or the kernel is not
  detecting the system correctly.

  I created a couple of pastebins with data collected:

  12.10 Install: http://pastebin.ubuntu.com/1561660/
  12.04 Live Disk (was checked against installed version and data is mostly the same): http://paste.ubuntu.com/1565140/

  I have a thread on the ubuntu forums that may provide additional
  details: http://ubuntuforums.org/showthread.php?t=2104709

  I also started an e-mail thread to the ubuntu-users mailing list:

  I have done a lot of troubleshooting and I feel that the problem must
  either be the kernel or the bios misrepresenting information. In
  either case I am stuck without any idea of where to go next with the
  debuging and diagnoses path.

  If any additional information needs to be collected, please let me know and I will work to assist.
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu17.1
  Architecture: i386
   /dev/snd/controlC1:  bakers     1729 F.... pulseaudio
   /dev/snd/controlC0:  bakers     1729 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
   Card hw:0 'PCH'/'HDA Intel PCH at 0xf7110000 irq 45'
     Mixer name	: 'Realtek ALC887-VD'
     Components	: 'HDA:10ec0887,1458a002,00100302'
     Controls      : 39
     Simple ctrls  : 20
   Card hw:1 'NVidia'/'HDA NVidia at 0xf7080000 irq 17'
     Mixer name	: 'Nvidia GPU 42 HDMI/DP'
     Components	: 'HDA:10de0042,14583553,00100100'
     Controls      : 18
     Simple ctrls  : 3
  DistroRelease: Ubuntu 12.04
   lo        no wireless extensions.
   eth0      no wireless extensions.
  MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
  MarkForUpload: True
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-36-generic-pae root=UUID=4f30252c-fa56-4d53-be78-117cddab55f4 ro quiet splash
  ProcVersionSignature: Ubuntu 3.2.0-36.57-generic-pae 3.2.35
   linux-restricted-modules-3.2.0-36-generic-pae N/A
   linux-backports-modules-3.2.0-36-generic-pae  N/A
   linux-firmware                                1.79.1
  StagingDrivers: mei
  Tags:  precise running-unity staging
  Uname: Linux 3.2.0-36-generic-pae i686
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 08/21/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F9
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: P75-D3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF9:bd08/21/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnP75-D3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To be filled by O.E.M.
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: