← Back to team overview

kernel-packages team mailing list archive

[Bug 1027368] Re: [Samsung NP530U3B-A01UK] Laptop does not suspend on lid close


Pat Robinson, could you please test the latest mainline kernel via
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc2-trusty/ and
advise to the results?

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Samsung NP530U3B-A01UK] Laptop does not suspend on lid close

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  I've installed Ubuntu 12.04 on my wife's laptop, (a Samsung NP530U3B), all goes well except when I close the lid it does not suspend. I've checked the settings and it is set to suspend on lid close, though does not. Things I've noticed are:
  1 - Clicking suspend in the power menu works fine.
  2 - When I cat /proc/acpi/button/lid/LID0/state it always returns open, even when closed, (I ran a script that looped the cat then closed the lid)
  3 - Running the latest Ubuntu 12.10 alpha 2 does not work either.
  4 - The latest mainstream kernel 'linux-image-3.5.0-999-generic_3.5.0-999.201207190406_i386' does not work either.
  5 - One odd thing was that after installing the latest bios on the laptop using Windows 7, then restarting into Ubuntu worked once, then it never worked again. I tried booting in to Windows then rebooting back in to Ubuntu to see if that is what changed something but it did not work that time.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-26-generic-pae 3.2.0-26.41
  ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
  Uname: Linux 3.2.0-26-generic-pae i686
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu11
  Architecture: i386
   **** List of CAPTURE Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  lou        2512 F.... pulseaudio
   Card hw:0 'PCH'/'HDA Intel PCH at 0xf0700000 irq 50'
     Mixer name	: 'Intel CougarPoint HDMI'
     Components	: 'HDA:10ec0269,144dc0c7,00100202 HDA:80862805,80860101,00100000'
     Controls      : 24
     Simple ctrls  : 11
  Date: Sat Jul 21 09:37:25 2012
  HibernationDevice: RESUME=UUID=3c27803e-5c58-4d5f-b649-d7357db99120
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 530U3BI/530U4BI/530U4BH
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic-pae root=UUID=36b0eced-301e-4fa8-a3e4-2c1466de4955 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-26-generic-pae N/A
   linux-backports-modules-3.2.0-26-generic-pae  N/A
   linux-firmware                                1.79
  SourcePackage: linux
  StagingDrivers: mei
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/11/2012
  dmi.bios.vendor: Phoenix Technologies Ltd.
  dmi.bios.version: 08XK
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 530U3BI/530U4BI/530U4BH
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: FAB1
  dmi.chassis.asset.tag: Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: 0.1
  dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr08XK:bd07/11/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn530U3BI/530U4BI/530U4BH:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn530U3BI/530U4BI/530U4BH:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
  dmi.product.name: 530U3BI/530U4BI/530U4BH
  dmi.product.version: 0.1
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to: