← Back to team overview

kernel-packages team mailing list archive

[Bug 921123] Re: ath5k Atheros AR5007G/AR2417 Chip Connected to Router but No Internet


I'm still on LTS Precise on v3.4, I got it working right after I reinstalled the card but it soon dropped the internet after about 30mins while still connected to the router.
I just installed v3.12.4, the internet connection seems stable. will wait for a few more hours and report back just to make sure.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ath5k Atheros AR5007G/AR2417 Chip Connected to Router but No Internet

Status in “linux” package in Ubuntu:

Bug description:
  I bought a TP-Link WN 350GD PCI Wifi Card with an Atheros chip. It worked well on Natty and Oneiric, until a few weeks ago (probably after a kernel upgrade) when it started acting funky. It's connected to the router alright, but the internet's either disconnected, or very very slow - slower than dialup. 
  Signal strength's good at 77%, authenticated via WPA2-Personal.

  I'm using both LAN and Wireless connections (LAN's routing is enabled)
  since LAN connection's for the internal network, while the wireless
  connection's for the Internet. I can usually scan and ping other
  devices/workstations connected wirelessly but not anymore. Every now
  and then, the wifi card would allow me to connect to a website at 15K-
  20Kbps, but it'll disconnect soon after. Syslog shows that the card
  keeps on re-authenticating to the network. Something that does not
  happen on my TP-Link USB Wifi with Ralink chipset - and they're
  averaging at 65%-75% signal strength.

  I've already tried booting to v2.6.39, v3.0.0-15, and v3.2.1 (which I got from kernel.ubuntu.com for precise pangolin) kernels with no success.
  I've even tried compiling compat-wireless by following the instructions on http://linuxwireless.org/en/users/Download#Directly_downloading_the_tarball
  I've also commented out ath_pci from /etc/modprobe.d/blacklist-ath_pci.conf
  all with the same result. 

  I haven't tried using wicd as suggested in the forum since it doesn't
  support simultaneous connections

  So is this an ath5k bug? or did my pci wifi card went south. I can't
  replace it at the moment since this is a company workstation and might
  take a while to get a replacement card.  By the way, the workstation
  I'm using is a dev workstation and a web/database/ntpd server for our
  prototypes which means it's on 24/7.

  [   14.895389] ath5k phy0: Atheros AR2417 chip found (MAC: 0xf0, PHY:

         description: Wireless interface
         product: AR5007G Wireless Network Adapter
         vendor: Atheros Communications Inc.
         physical id: 1
         bus info: pci@0000:03:01.0
         logical name: wlan0
         version: 01
         serial: 74:ea:3a:af:8b:53
         width: 32 bits
         clock: 33MHz
         capabilities: pm bus_master cap_list ethernet physical wireless
         configuration: broadcast=yes driver=ath5k driverversion=3.0.0-15-generic firmware=N/A latency=168 link=no maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
         resources: irq:20 memory:febf0000-febfffff

  ProblemType: Bug
  DistroRelease: Ubuntu 11.10
  Package: linux-image-3.0.0-15-generic 3.0.0-15.26
  ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
  Uname: Linux 3.0.0-15-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 1.23-0ubuntu4
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
     Subdevices: 2/2
     Subdevice #0: subdevice #0
     Subdevice #1: subdevice #1
   /dev/snd/controlC0:  dax        2436 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'Intel'/'HDA Intel at 0xfe978000 irq 43'
     Mixer name	: 'VIA VT1708S'
     Components	: 'HDA:11060397,104383b7,00100000'
     Controls      : 35
     Simple ctrls  : 20
  Date: Wed Jan 25 01:56:51 2012
  HibernationDevice: RESUME=UUID=ff47f150-5c4f-4c0f-beef-fcea86774303
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
  MachineType: System manufacturer System Product Name
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=5c9d3133-32f6-4833-ac13-75a03cfff0ab ro quiet splash vt.handoff=7
   linux-restricted-modules-3.0.0-15-generic N/A
   linux-backports-modules-3.0.0-15-generic  N/A
   linux-firmware                            1.60
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/04/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0415
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5KPL-AM EPU
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: x.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0415:bd02/04/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5KPL-AMEPU:rvrx.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  ApportVersion: 1.23-0ubuntu4
  Architecture: amd64
  DistroRelease: Ubuntu 11.10
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
  Package: linux (not installed)
  Tags:  oneiric running-unity
  Uname: Linux 3.2.0-030200-generic x86_64
  UnreportableReason: The running kernel is not an Ubuntu kernel
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm admin lpadmin netdev sambashare

To manage notifications about this bug go to: