← Back to team overview

kernel-packages team mailing list archive

[Bug 565892] Re: ath5k driver (AR2413): dropped packets, high latency


sml, this bug was reported a while ago and there hasn't been any
activity in it recently. We were wondering if this is still an issue? If
so, could you please test for this with the latest development release
of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
/daily-live/current/ .

If it remains an issue, could you please run the following command in
the development release from a Terminal
(Applications->Accessories->Terminal), as it will automatically gather
and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** This bug is no longer a duplicate of bug 568090
   ath5k should be loaded with nohwcrypt parameter

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ath5k driver (AR2413): dropped packets, high latency

Status in “linux” package in Ubuntu:

Bug description:
  Using the ath5k driver (AR2413 chip) on the lucid kernel I get high
  latencies and dropped packets. eg. Web pages load slowly if at all. I
  believe it is related to this bug in fedora:

  I tried installing linux-backports-modules-wireless-lucid-generic
  (linux-backports-modules-wireless-2.6.32-21-generic at the time of
  this report) and also tried loading ath5k with:

  modprobe ath5k nohwcrypt=1
  modprobe ath5k nohwcrypt=0

  Neither of these had any effect on the problem. However, installing the 2.6.33 kernel from the mainline ppa fixes the problem completely!

  I will attach the results of pinging my router under both the 2.6.32
  and 2.6.33 kernels for proof of the fix.

  A backported patch for the lucid kernel would be great! :-)

  ProblemType: Bug
  DistroRelease: Ubuntu 10.04
  Package: linux-image-2.6.32-21-generic 2.6.32-21.32
  Regression: No
  Reproducible: Yes
  ProcVersionSignature: Ubuntu 2.6.32-21.32-generic
  Uname: Linux 2.6.32-21-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
  Architecture: amd64
   /dev/snd/controlC1:  scottl     1559 F.... kmix
   /dev/snd/controlC0:  scottl     1559 F.... kmix
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'Intel'/'HDA Intel at 0xe9300000 irq 22'
     Mixer name	: 'Realtek ALC889A'
     Components	: 'HDA:10ec0885,1458a002,00100101'
     Controls      : 43
     Simple ctrls  : 24
   Card hw:1 'HDMI'/'HDA ATI HDMI at 0xe5010000 irq 17'
     Mixer name	: 'ATI R6xx HDMI'
     Components	: 'HDA:1002aa01,00aa0100,00100100'
     Controls      : 4
     Simple ctrls  : 1
   Simple mixer control 'IEC958',0
     Capabilities: pswitch pswitch-joined penum
     Playback channels: Mono
     Mono: Playback [off]
  Date: Sun Apr 18 19:11:48 2010
  HibernationDevice: RESUME=UUID=3d5ade3c-5b98-4b53-8040-51f5e201bc40
  InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
  MachineType: Gigabyte Technology Co., Ltd. EP45-DS3
  ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=48631c15-5a8c-4695-8ef0-a258637d1b0b ro quiet splash
  RelatedPackageVersions: linux-firmware 1.34
  SourcePackage: linux
  dmi.bios.date: 07/23/2008
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F7
  dmi.board.name: EP45-DS3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd07/23/2008:svnGigabyteTechnologyCo.,Ltd.:pnEP45-DS3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP45-DS3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: EP45-DS3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: