← Back to team overview

kernel-packages team mailing list archive

[Bug 665918] Re: Media keys not working in Toshiba Satellite U500


I know this bug has expired but I would like to provide updated
information for anyone still using the Toshiba Satellite U500.

With Ubuntu 13.10 the product name is reported as "Satellite U500"
instead of "SATELLITE U500". This breaks the previous fix for the volume
keys in Ubuntu bug #271706.

To fix this issue add the following to

# Satellite U500

The above hwdb rule should match both "Satellite U500" and "SATELLITE

Now update the hardware database information.

sudo udevadm hwdb --update

The other media keys are still not working as reported in this bug.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Media keys not working in Toshiba Satellite U500

Status in “linux” package in Ubuntu:

Bug description:
  Binary package hint: udev

  The special media keys in the Toshiba Satellite U500 do not work.
  Following the instructions in /usr/share/doc/udev/README.keymap.txt.gz
  I've tried to create a keymap to sort this out (attached), with not
  very good results:

  *The mute key was originally mapped to 'd'. Apparently it is linked to
  the 'd' key itself, because changing the mapping of this key also
  changes the mapping of the 'd' key to mute! This makes the keyboard
  unusable, of course.

  * Next/previous track do not work, even with the mapping attached.

  * There is a key -supposed to launch the media player- that does not
  do anything even under sudo /lib/udev/keymap -i input/event3. This key
  works in Windows.

  I'm using Ubuntu 10.10, and udev version 162-2.1

  The output of  cat /sys/class/dmi/id/sys_vendor is TOSHIBA
  The output of  cat /sys/class/dmi/id/product_name is SATELLITE U500

  Thanks for your help. Cheers,

To manage notifications about this bug go to: