← Back to team overview

kernel-packages team mailing list archive

[Bug 1007142] Re: Unaccounted space loss when formating partition to EXT4


Alex Moldovan, this bug was reported a while ago and there hasn't been
any activity in it recently. We were wondering if this is still an
issue? If so, could you please test for this with the latest development
release of Ubuntu? ISO images are available from
http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in
the development release from a Terminal
(Applications->Accessories->Terminal), as it will automatically gather
and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** Tags added: bios-outdated-a16 needs-upstream-testing

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Unaccounted space loss when formating partition to EXT4

Status in “linux” package in Ubuntu:

Bug description:
  For a long time I've had 2 identical drives that I want to migrate
  from NTFS to EXT4. They are the same size, brand..etc. I only used
  them for backup so I alway sync them to duplicate data on them. I have
  formated one to EXT4 reducing the reserved block percentage to 0 (-m
  0) having the following features:

  has_journal ext_attr resize_inode dir_index filetype needs_recovery
  extent flex_bg sparse_super large_file huge_file uninit_bg dir_nlink

  Already after formatting it shows 28GB of used space and it about the same amount of data that I can't copy from the NTFS drive.
  After tuning the filesystem I have done a e2fsck to make sure things are OK. Still, there's ~30GB missing space. When I tried to copy back the data from the NTFS drive to the EXT4 it fails to copy ~ 30GB of data.

  I am running Precise with 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64. I will attach the all data from both drives: /dev/sdb1 is the NTFS drive and /dev/sdc1 is the EXT4 drive. I am not sure if this is a normal or a bug but there's ~30GB of unaccounted missing space on the EXT4. Reformatting back to NTFS gives me back those 30GB. I have tried this multiple times.
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu8
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
     Subdevices: 2/2
     Subdevice #0: subdevice #0
     Subdevice #1: subdevice #1
   /dev/snd/controlC0:  alex       2949 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'Intel'/'HDA Intel at 0xfe6dc000 irq 51'
     Mixer name	: 'Analog Devices AD1984A'
     Components	: 'HDA:11d4194a,1028027f,00100400'
     Controls      : 34
     Simple ctrls  : 20
  DistroRelease: Ubuntu 12.04
  HibernationDevice: RESUME=UUID=2c8aae11-d4df-4920-acc5-5041b51e94f0
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
   lo        no wireless extensions.
   eth0      no wireless extensions.
  MachineType: Dell Inc. OptiPlex 760
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=768470c2-a727-44f8-800b-6606c3c5c948 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
   linux-restricted-modules-3.2.0-24-generic N/A
   linux-backports-modules-3.2.0-24-generic  N/A
   linux-firmware                            1.79
  SourcePackage: linux
  StagingDrivers: mei
  Tags:  precise staging precise staging
  Uname: Linux 3.2.0-24-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 02/18/2009
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.name: 0G919G
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 16
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA02:bd02/18/2009:svnDellInc.:pnOptiPlex760:pvr:rvnDellInc.:rn0G919G:rvrA00:cvnDellInc.:ct16:cvr:
  dmi.product.name: OptiPlex 760
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: