← Back to team overview

kernel-packages team mailing list archive

[Bug 1055192] Re: After 1000's of small connections traffic on those connections stop


Pieter De Wit, this bug was reported a while ago and there hasn't been
any activity in it recently. We were wondering if this is still an
issue? If so, could you please test for this with the latest development
release of Ubuntu server? ISO images are available from
http://cdimage.ubuntu.com/ubuntu-server/daily/current/ .

If it remains an issue, please just make a comment to this.

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  After 1000's of small connections traffic on those connections stop

Status in “linux” package in Ubuntu:

Bug description:

  I have two VM's setup with e1000 drivers. I use iperf in server mode
  on the one and in client mode on the other. On the client I run the
  following in a while "true" loop:

  iperf -c <server_ip> -P 8 -i 5 -l 1k

  I run about 50 of those in background.

  After about 40 seconds traffic just stops. new connections are still
  made and working, but these all stop. Something like ping never stops
  and I can ssh to the box and all other connections are maintained.

  I do see a message in the kernel about SYN cookies being sent, but
  disabling this doesn't solve the problem.

  Switching the network to vmnet3 solves the problem, but this has a
  bunch of issues itself.

  Thanks !
   total 0
   crw-rw---T 1 root audio 116,  1 Sep 24 13:51 seq
   crw-rw---T 1 root audio 116, 33 Sep 24 13:51 timer
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.0.1-0ubuntu12
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CRDA: Error: [Errno 2] No such file or directory
  DistroRelease: Ubuntu 12.04
  HibernationDevice: RESUME=UUID=66a69b7d-4300-4a87-b29c-800606259ff1
  InstallationMedia: Ubuntu-Server 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120817.3)
   lo        no wireless extensions.
   eth1      no wireless extensions.
   eth0      no wireless extensions.
  Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
  MachineType: VMware, Inc. VMware Virtual Platform
  Package: linux (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic root=UUID=862e0352-b410-4629-9745-678a00ad837b ro
  ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
   linux-restricted-modules-3.2.0-31-generic N/A
   linux-backports-modules-3.2.0-31-generic  N/A
   linux-firmware                            1.79.1
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  precise
  Uname: Linux 3.2.0-31-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
   Sep 25 09:56:31 gsr1qmg01 kernel: [72140.975082] tcpdump uses obsolete (PF_INET,SOCK_PACKET)
   Sep 25 09:56:35 gsr1qmg01 kernel: [72145.238366] device eth0 entered promiscuous mode
  dmi.bios.date: 06/22/2012
  dmi.bios.vendor: Phoenix Technologies LTD
  dmi.bios.version: 6.00
  dmi.board.name: 440BX Desktop Reference Platform
  dmi.board.vendor: Intel Corporation
  dmi.board.version: None
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 1
  dmi.chassis.vendor: No Enclosure
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd06/22/2012:svnVMware,Inc.:pnVMwareVirtualPlatform:pvrNone:rvnIntelCorporation:rn440BXDesktopReferencePlatform:rvrNone:cvnNoEnclosure:ct1:cvrN/A:
  dmi.product.name: VMware Virtual Platform
  dmi.product.version: None
  dmi.sys.vendor: VMware, Inc.

To manage notifications about this bug go to: