← Back to team overview

kernel-packages team mailing list archive

[Bug 1082418] [NEW] Ubuntu UEFI install locks out UEFI firmware (~bios) access


You have been subscribed to a public bug:

lsb_release -rd
Description:	Ubuntu 12.10
Release:	12.10

apt-cache policy grub-efi-amd64
  Installed: 2.00-7ubuntu11
  Candidate: 2.00-7ubuntu11

Pheonix Secure Core Tiano bios version 1.09

New laptop Fujitsu Lifebook AH532. Windows 7 preinstalled. All functions
worked normally when running Win7. Ubuntu 12.10 installed using whole
disk. Installation successful Ubuntu boots and runs normally, however
all access to the bios has now been lost. Pressing the default key (f2)
during boot up is acknowledged by bios beep, but ignored and Ubuntu
continues booting. In addition the 'boot choices' menu (f12) contains
nothing but Ubuntu making it impossible to boot from USB or CD/DVD.

The latter (f12) problem was overcome by opening up the machine,
removing the ram and shorting the cl1/cl2 posts with a screwdriver. This
restores the ability to boot from USB/CD by pressing f12 but does not
restore bios access.

The following recovery actions have been tried.
1) Install Boot-Repair, run repair, no change occurred. Boot repair report here:

2) Restore Windows from Clonezilla disk image (factory settings) -
result - bios access is no longer possible from windows either, f2 now
launches the Windows boot menu.

3) Update all drivers using Fujitsu driver update tool from within
windows (which included a bios update). Result - no change, no bios.

4) Restored Ubuntu from Clonezilla disk image - no change.

5) Added second distro to disk. Installed successfully (uefi mode as
that is all I have) no change to bios access.

So overall result I have lost all bios access even from a reinstalled
Windows. I repeat that bios access was perfectly normal before
installing Ubuntu.

I strongly suggest you read the contents of this thread in addition to
the information here:


ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub-efi 2.00-7ubuntu11
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Fri Nov 23 15:50:07 2012
InstallationDate: Installed on 2012-11-22 (1 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: linux (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug quantal running-unity
Ubuntu UEFI install locks out UEFI firmware (~bios) access
You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.