← Back to team overview

kernel-packages team mailing list archive

[Bug 1058854] Re: High CPU usage of CFS


I no longer have access to this hardware to get the full computer model,
but the referenced test programs should be able to reproduce the issue
on most, if not all machines (it's worked on everyone I've tried it on
to date).

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  High CPU usage of CFS

Status in “linux” package in Ubuntu:

Bug description:
  It appears that there is an issue with the Completely Fair Scheduler (CFS) not intereacting well with sleep commands. I have written up a test program to help demonstrate the issue and it can be found at:
  The test outputs wall time (CPU clock), user time, and system time, but usually only the wall time and user time outputs are meaningful because the system time is so small and usually within the standard deviation for all tests.

  I have also attached the results from running this test on an HP
  Pavilion dm4 and I believe that the gap at the low number of threads
  is caused by either the processor going into a power saving state
  because of  the sleeping and/or a poor interaction with HyperThreading
  (scheduling the 2 threads on logical cores rather than separate
  physical cores).

  Because of this, I then ran 4 instances of:
  schedtool -a <CPU#> -e nice -19 yes > /dev/null
  so that all of the cores would be kept busy during the sleeping and this had an unexpected effect of causing the wall time to increase significantly. I am not sure what the cause of the wall time increase is, but it does help the user time plot display the gap between the sleep methods and the none sleep methods that I believe is a symptom/display of the unexpectedly high CPU usage when the process should be sleeping.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-31-generic 3.2.0-31.50
  ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
  Uname: Linux 3.2.0-31-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu13
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  dlj        1778 F.... pulseaudio
   Card hw:0 'PCH'/'HDA Intel PCH at 0xc0800000 irq 50'
     Mixer name	: 'Intel CougarPoint HDMI'
     Components	: 'HDA:111d76e0,103c1793,00100102 HDA:80862805,103c1793,00100000'
     Controls      : 22
     Simple ctrls  : 10
  Date: Fri Sep 28 20:57:35 2012
  InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
  MachineType: Hewlett-Packard HP Pavilion dm4 Notebook PC
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic root=UUID=162256F02256D479 loop=/hostname/disks/root.disk ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-31-generic N/A
   linux-backports-modules-3.2.0-31-generic  N/A
   linux-firmware                            1.79.1
  SourcePackage: linux
  StagingDrivers: rts_pstor mei
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/17/2012
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: F.08
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 1793
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 41.1C
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnHewlett-Packard:bvrF.08:bd01/17/2012:svnHewlett-Packard:pnHPPaviliondm4NotebookPC:pvr068E100002204710000622100:rvnHewlett-Packard:rn1793:rvr41.1C:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.name: HP Pavilion dm4 Notebook PC
  dmi.product.version: 068E100002204710000622100
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: